Website weird issue needs fixed ASAP

Permalink
If you go to my website via IP address it works great
http://173.254.28.116/~nccacoop/content/...

However if you go to the domain name it is broke? any idea why it is the same location
http://www.ncca.net/content

timstrathman
View Replies:
mhawke replied on at Permalink Reply
mhawke
Have you submitted a support ticket with your host?
timstrathman replied on at Permalink Reply
timstrathman
They said it's a concrete 5 issue and I believe it is.... I think the base url is pointing somewhere wrong but there is no site.php file
mhawke replied on at Permalink Reply
mhawke
I don't know where 5.7 keeps this info but hosts often blame the CMS when, in fact, something is wrong with their configuration that caused the CMS to misinterpret things. Hopefully someone here knows where 5.7 stores it's path info. Have a look in root/application/config/generated_overrides/concrete.php . That's the only place I could find my base URL under SEO
timstrathman replied on at Permalink Reply
timstrathman
I found Canical URL is set to ' ' what should it be? They keep saying its on my end...
timstrathman replied on at Permalink Reply
timstrathman
I found in the dashboard where it sets Canoical URL would I set it there? Looks like if you set it and its not working its a pain to redo that setting. Its just weird that the IP address works but going tohttp://www.ncca.net/content which is the same location pulls up a version of the site with no framework essentially
mhawke replied on at Permalink Reply
mhawke
Yes, changing it in the dashboard kills your site but it can be fixed again by editing the SEO section of:

/application/config/generated_overrides/concrete.php

Throw this single line of PHP code into a file in the /content folder and save it as phpinfo.php

<?php echo phpinfo(); ?>

then hit it by going here:

http://173.254.28.116/~nccacoop/content/phpinfo.php...

You should see what PHP is reporting as your domain.