Which PHP version for C5 8.5.2

Permalink
Hello

My website is running with one of the last versions of C5 : 8.5.2.
But my PHP version is very old (5.3) so I should update it to recent versions like 7.3.

On this C5 page,https://documentation.concrete5.org/developers/introduction/system-r... they say to install PHP7.3 for C5 8.5+ versions.

But when I read the comments on the same page, several people are warning that PHP 7.3 doesn't work... These comments are 2 years old, can I now update to PHP 7.3 with my C5 8.5.2 version ?
Please confirm

Thank you for your help
OIivier

View Replies:
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
Yes, C5 works fine on PHP 7.3. I'm running several sites on this version with no issues.
mnakalay replied on at Permalink Reply
mnakalay
It works fine with PHP 7.4 as well. I'm using it with 7.4.1
Steevb replied on at Permalink Reply
Steevb
We're running several sites with 7.4.7 in a 'LiteSpeed' server, all works.
Do you have cPanel to self update, if not try asking you're hosting company to update.