Wrong system Time

Permalink 3 users found helpful
I just noticed that for some reason my concrete5 install adds about 4 hours to my al date/time values like Last logged in and Page Add times. Why does it do this? I have checked and triple checked and even reset my server system time and it set to my time, yet concrete5 thinks it is 4 hours into the future.

Anybody know how to fix this?

ideasponge
View Replies: View Best Answer
ideasponge replied on at Permalink Reply
ideasponge
Any clues at all?
ryan replied on at Permalink Best Answer Reply
ryan
So, there are two features new in 5.3.3:

To configure your default timezone
Add this to your site.php
<?php
define('APP_TIMEZONE','America/New_York');
?>


The allowed timezones are here:
http://www.php.net/manual/en/timezones.php...

You can also enable user defined timezones in the Dashboard -> Users and Groups -> Login & Registration

Then you can set the timezone for each user.
ideasponge replied on at Permalink Reply
ideasponge
thanks a bunch
Benji replied on at Permalink Reply
Benji
I've defined a timezone in my config/site.php file, but still times are showing up in GMT. Tried clearing the cache, but no change. Anyone know?
ideasponge replied on at Permalink Reply
ideasponge
Do you have it set for User Defined Time Zones in the Login & Registration page?
pakigreenl replied on at Permalink Reply
pakigreenl
that's great. it changed my log-in time for site activity but would not changes my report/log times. any reason that those don't change? how can i make them?
Mnkras replied on at Permalink Reply
Mnkras
i believe thats a bug
campbell replied on at Permalink Reply
campbell
I think this bug is still there in 5.4.2.2. I updated a page, and the excellent Event Tester add-on identified the new version as being created at 12:37pm (which is the correct time). However, in the Logs section of the Dashboard, the Event Tester log is listed as occurring at 6:37pm (which is so NOT the correct time).

I have my timezone set correctly in the site.php file, and the correct times show up in the database, so that's good... but the wrong times in the Logs area are misleading.

Has anyone identified a fix for this yet?
ideasponge replied on at Permalink Reply
ideasponge
Metaglyphics replied on at Permalink Reply
Does anyone know if this bug has been resolved? I've specified the time zone in config/site.php, .htaccess and php.ini. But guestbook posts are still stamped with the wrong time...

Thanks
Korvin replied on at Permalink Reply
Korvin
If you have shell access, ssh into your server and run Compare the output with your current time, if it's wrong you'll have to set your date manually (also maybe your hardware clock)

Check outhttp://www.hypexr.org/linux_date_time_help.php...

Remember that linux distributions can vary, so it'd be beneficial to search specifically for updating the date setting on your server distrobution.