5.7.1 Install - SQL Error - Database Setup

Permalink
FTP upload fine.

Test page fine.

Database error on setup:

SQLSTATE[28000] [1045] Access denied for user ' domain'@'xx.xxx.xx.xxx.' (using password: YES)

Please help!

kerofai
View Replies:
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi kerofai,

Look in application\config\database.php and check the values.

Here is an example:
return array(
    'default-connection' => 'concrete',
    'connections' => array(
        'concrete' => array(
            'driver' => 'c5_pdo_mysql',
            'server' => 'localhost', // server information
            'database' => 'concrete5', // database name
            'username' => 'tootiefrootie', // database username
            'password' => 'meatloaf', // database password
            'charset' => 'utf8'
        )
    )
);
negs replied on at Permalink Reply
I'm not the original poster but I'm having the same problem. But then I changed my server from my domain to 'localhost' and it went through.

However, in case someone else shows up, I'd like to note that the file that you suggested the original poster look at did not exist. Did you mean concrete\config\database.php?
mhawke replied on at Permalink Reply
mhawke
'localhost' is the typical value. If you put the wrong value in there, like your domain, then the installation will crash before it has a chance to create the database.php file in the 'application/config/' folder mentioned above.
DynamicFred replied on at Permalink Reply
DynamicFred
I'm not the original poster but am getting the same error. All permissions are set correctly, server is set to localhost (tried 127.0.0.1 as well).

Anyone have any ideas?
DynamicFred replied on at Permalink Reply
DynamicFred
Found it. Typo in the password.
hudsonarmstrong replied on at Permalink Reply
I'm also experiencing a similar install issue.

I am trying to install at 1&1 and have received confirmation via the hosting company that my database details are correct but I'm seeing the "SQLSTATE[HY000] [2002] Connection refused" error.
robodev replied on at Permalink Reply
I think what is very useful, if you can, is to setup Phpmyadmin (or see if your ISP has a database interface).

There are several things that can be wrong. For example, sometimes with mySQL the admin can accidentally create an account with % as the server versus localhost, or with 127.0.0.1. The only way to be 100% sure is to either create the database and/or database account yourself, or at the very least login yourself with those credentials.
hudsonarmstrong replied on at Permalink Reply
Thanks, I will check.
TheRealSean replied on at Permalink Reply
TheRealSean
Try the following for 1and1 (note the socket parameter)
return array(
    'default-connection' => 'concrete',
    'connections' => array(
        'concrete' => array(
            'driver' => 'c5_pdo_mysql',
            'server' => 'localhost',
            'database' => 'dbName',
            'unix_socket' => '/tmp/mysql5.sock',
            'username' => 'dbUsername',
            'password' => 'dbPassword',
            'charset' => 'utf8'
        )
    )
);
TheRealSean replied on at Permalink Reply
TheRealSean
To do this from a fresh install (on the install page) I had to tweak the host name a little ;) to include the socket

'localhost;unix_socket=/tmp/mysql5.sock',
jeromeb replied on at Permalink Reply
Hi,

Can someone please help me? I'm trying to change my dbase information by following the instructions here.

Upon opening concrete/config/database.php, all I see is the code below. Where do i find the code that is mentioned in this thread so I can change the dbase name, username, and password?

Thanks a bunch. Hoping for someone's reply soon.
<?php
return array(
    'drivers' => array(
        'c5_pdo_mysql' => '\Concrete\Core\Database\Driver\PDOMySqlConcrete5\Driver'
    ),
    /**
     * The location of the doctrine Proxy Classes
     */
    'proxy_classes' => DIR_BASE_CORE . '/config/doctrine/proxies',
    /**
     * The database charset
     */
    'charset' => 'utf8'
);
mhawke replied on at Permalink Reply
mhawke
application/config/database.php
jeromeb replied on at Permalink Reply
My bad, I was in the wrong directory. Thank you very much!
sbuompi replied on at Permalink Reply
I have the same problem:
SQLSTATE[28000] [1045] Access denied for user 'xxxxxxxxxx'@'hostgator.com' (using password: YES)
application/config the config folder is empty
could someone help me

Please help