install fails with MAMP on macOS


I'm trying to install concrete5 with a MAMP server for local development and testing. I'm having trouble getting it to install on my machine. I have followed various steps and tips that other users have tried but so far none have been successful for me.

I have MAMP up and running and concrete5 placed in the htdocs folder, this allows me to run through an installation but after I enter my database information I get the stack trace below. I have tried creating a new DB but I get the same error.

I've tried with a DB and removing the super permission, this however didn't work.

MAMP: 3.5

stack trace:
Unable to install database: Declaration of Concrete\Core\Attribute\Key\CollectionKey::getList() should be compatible with Concrete\Core\Attribute\Key\Key::getList($akCategoryHandle, $filters = Array).
#0 [internal function]: Concrete\Core\Package\StartingPointPackage->install_database() #1 /Applications/MAMP/htdocs/concrete5.7.5.3/concrete/controllers/Install.php(275): call_user_func(Array) #2 [internal function]: Concrete\Controller\Install->run_routine('elemental_full', 'install_databas...') #3 /Applications/MAMP/htdocs/concrete5.7.5.3/concrete/src/Controller/AbstractController.php(156): call_user_func_array(Array, Array) #4 /Applications/MAMP/htdocs/concrete5.7.5.3/concrete/src/Routing/ControllerRouteCallback.php(25): Concrete\Core\Controller\AbstractController->runAction('run_routine', Array) #5 /Applications/MAMP/htdocs/concrete5.7.5.3/concrete/src/Routing/Router.php(115): Concrete\Core\Routing\ControllerRouteCallback->execute(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Routing\Route), Array) #6 /Applications/MAMP/htdocs/concrete5.7.5.3/concrete/src/Support/Facade/Facade.php(119): Concrete\Core\Routing\Router->execute(Object(Concrete\Core\Routing\Route), Array) #7 /Applications/MAMP/htdocs/concrete5.7.5.3/concrete/src/Application/Application.php(392): Concrete\Core\Support\Facade\Facade::__callStatic('execute', Array) #8 /Applications/MAMP/htdocs/concrete5.7.5.3/concrete/bootstrap/start.php(256): Concrete\Core\Application\Application->dispatch(Object(Concrete\Core\Http\Request)) #9 /Applications/MAMP/htdocs/concrete5.7.5.3/concrete/dispatcher.php(36): require('/Applications/M...') #10 /Applications/MAMP/htdocs/concrete5.7.5.3/index.php(2): require('/Applications/M...') #11 {main}

Has anyone else came across this issue and or can help?


View Replies:
Steevb replied on at Permalink Reply
This is what I've done:
1. In 'htdocs' I create new folder. Lets say 'test'.
2. I copy all contents of the 'concrete5.7.5.3' folder and paste into the 'test' folder.
3. I click 'Open WebStart page' from the 'MAMP' dialogue box.
4. I hover over 'Tools' in the Safari browser and click 'phpMyAdmin'.
5. In new Safari tab I click 'New' in left hand side of window.
6. Type a name in the 'Database name' text field (I typed 'test') and then choose 'utf8_general_ci' from the dropdown and then click 'Create'.
7. in any browser type in url:http://localhost:8888/test/

This then should start the install process. I have over thirty installs, no errors.

Try it and see how you get on.
keithdarragh replied on at Permalink Reply
Unfortunately I have already tried this but it still fails on the install, producing the stack trace. Is there anything else you know of that might affect this?
Steevb replied on at Permalink Reply
This is a fresh install of

What Mac r u using, what version of OSX have you got?

I don't see php5.5.14

I only have 5.5.26 or 5.6.10
burtondev replied on at Permalink Reply
Same thing just happened to me with what appears to be the same error message. I'm running MAMP on Windows 8.1. I just upgraded MAMP yesterday or the day before. Could it have something to do with the upgrade?
burtondev replied on at Permalink Reply
@keithdarragh, I found a solution! Maybe it will work for you too, or at least give you a starting point to figure things out :-)

What caused this error in my case was not using a compatible version of PHP. I just updated to the most recent version of MAMP and began running PHP 7.0 So I switched back to 5.6.13, and now the database has installed without any errors.

I'm a little confused about the version of MAMP you are using. You wrote "MAMP 3.5", however MAMP & MAMP PRO 3.2 was just published 3 days ago. Did you mean 3.2?

If you have an older version of MAMP, try updating to 3.2. But regardless you should try using PHP 5.6.13 and see if it helps. You can do this from the main MAMP UI: select "Preferences...". When it pops up, switch to the PHP tab. From there, change "Standard Version" to 5.6.13 and click "OK". Then once that processes, try reinstalling your concrete5 database. Please let me know if this was any help to you.
keithdarragh replied on at Permalink Reply
@burtondev The latest version of MAMP for windows is 3.2 but for Mac the latest version is 3.5.

I'll try and update my php version next and see if that helps, thanks. I'll let you know if that resolves my issue.
burtondev replied on at Permalink Reply
Were you able to resolve your issue?
eivissa89 replied on at Permalink Reply
great! that helped me a lot!

by the way, did anyone ever use MAMP for a website which should be opened only local with roughly 100 iPads?
burtondev replied on at Permalink Reply
Glad to hear that this thread helped you!

I haven't used MAMP in the scenario that you described. All the best!