500 internal server error

Permalink 1 user found helpful
Hi all,

C5 newbie.

Installed 5.4.1.1 on my hosting account with hostpapa - all looks fine with basic install with dummy content, except when I go to the blog section I get a 500 internal server error. Home and About pages seem fine.

When I installed, it took me a while to realise that my unzip programme was ignoring empty folders, so following advice on this forum I had to create the packages folder manually and set its permissions to 755, which seemed to work, however, I didn't recreate any other empty folders.

Would this cause a 500 error ?

I searched for any pages with titles relating to blog and they all seem to have permissions of 644, is this right ?

Also, I wasn't sure what to put in the 'server' field on the initial installation page, so following more reading of this forum, I ended up putting 'localhost' even though installing to a hosted server, but it seemed to work until the blog problem - is this right ?

Should I just delete all and start from scratch using a different unzip programme that puts in empty folders, or is there something quicker I could try.

Thanks for any help or suggestions.

View Replies: View Best Answer
gderwent replied on at Permalink Reply
Any ideas anyone ?

I deleted and recreated the database, cleared all the files off the server, made sure that this time even empty folders were all unzipped properly and went through the install again, but still get a 500 error on the blog section.

Help !
jfuqua replied on at Permalink Reply
jfuqua
Same issue here. I get the 500 internal server error when selecting the following links:

From the dashboard: Site Map
From the blog page: On any linked blog titles on the sidebar, blog titles, read full post links.

It is somewhat confusing because I've had each link successfully at one time or another. It seems totally random.
jfuqua replied on at Permalink Reply
jfuqua
I just cleared out the cache and got a blog post and the sitemap to show up. If I try to go to another blog entry or leave and come back to the sitemap, the 500 internal server error shows up again.

Very puzzling.
jfuqua replied on at Permalink Reply
jfuqua
I disabled "Basic Cache" under "Speed Settings" which is one of the "Sitewide Settings" on your dashboard.

It's allowing me to view the pages which were previously giving me 500 errors.
gderwent replied on at Permalink Reply
Hey thanks for yor reply jfuqua,

You are right that the site map from the dashboard produced a 500 error for me too, just like you.

I tried what you suggested, cleared the cache and disabled basic cache, and the blog page on the public site was suddenly working ! However, for me the site map on the dashboard continues to give a 500 error. On the plus side, I've been in and out of the site a few times and the blog page continues to work.

I'll continue testing the blog page and tinker with the cache setting and post any success here. If you have any more luck in working out the problem, please let me know, or if anyone else can help, please chip in.

Thanks again for your help jfuqua.
Pritam replied on at Permalink Reply
Pritam
The \packages dir need to have 777 and not 755 , Besides this make the \config also needs 777 permission and finally the \files dir needs 777 but recursive to files and sub-directories.
jfuqua replied on at Permalink Reply
jfuqua
Thanks for the reply. What does "recursive to files and sub-directories" mean?
Pritam replied on at Permalink Reply
Pritam
Recursive to files and sub-directories means that you need to set chmod 777 on \files and all the files and sub-directories that exist within this directory.

If you are using filezilla ftp client, you shall find the option to choose recursive to files and sub-directories
jfuqua replied on at Permalink Reply
jfuqua
Understood. Thanks again.
gderwent replied on at Permalink Reply
Thanks Pritam, I'll try that too later on, no access to my server right now.

As I'm new to all this server permissions stuff, I thought 777 was quite dangerous and to be avoided as it gives everyone access, but presumably this is okay in certain files and folders ?
Pritam replied on at Permalink Best Answer Reply
Pritam
Yes 777 is required on the three dirs mentioned above, the files dir stores all the files that are uploaded via the file manager in the dashboard, since these files are used on some or most parts of your website content they require this permission.
gderwent replied on at Permalink Reply
Hi Pritam,

I just wanted to say thanks for helping me back in July. I had to leave the project for a while due to other commitments, but am now back on it. I started from scratch with the newer version of C5 which has become available since, and this just worked first time. I still don't really know what I was doing wrong before.

So, although I didn't use your answers to directly fix my problem, the fact that someone answered so quickly and was keen to help, gave me confidence in C5 and the C5 community, which made me persevere with it all, and everything has turned out well.

Thanks again
Gary