8.3.2 sitemap not working (404 not found instead of the tree)

Permalink
I'm not sure I've put this is in the right forum, but as it is a pretty fresh install I thought it might go here.

I've installed c5 8.3.2 and the Framework theme (using the starting point data which comes with the theme). All the things I tried so far worked pretty good, but today I wanted to try some things in the pagemap and what I get is a sitemap where the root tree says: Not found.

Problem is, I'm not finding any clues as to what is going wrong.

My apache2 and php-fpm error log does not contain any usable error message. The debug output of c5 does not generate anything on the sitemap and all I can gather is from the access log:
91.89.85.136 - - [02/Jun/2018:09:41:56 +0200] "GET /index.php/ccm/system/page/sitemap_data?displayNodePagination=0&cParentID=0&siteTreeID=0&displaySingleLevel=0&includeSystemPages=0&_=1527925402370 HTTP/1.1" 404 543 "https://correctaddress/index.php/dashboard/sitemap/full" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.91 Safari/537.36 Vivaldi/1.92.917.35"

I tried generating the pagemap.xml which succeeded, clearing the cache which didn't change anything. So I'm a bit at a loss here, some ideas what I could try to get my sitemap working?

Arsenal
View Replies:
Arsenal replied on at Permalink Reply
Arsenal
After leaving it for some hours it suddenly started to work - which is a bit strange...
Gondwana replied on at Permalink Reply
Gondwana
Caching.

When developing, turn off all caching you can get access to: c5, varnish, Cloudflare, even browser (especially if Chrome).
Pixelfixer replied on at Permalink Reply
Pixelfixer
I'm seeing the same problem and can't seem to resolve it. I've confirmed it's not a caching problem. I too am using the Framework theme and a relatively new site using the C5 core version 8.3.2. It was working fine for the first couple of months, but then, a couple days ago I went to change something on the site map and can't access it. When I click on Sitemap it starts to load the page and then just displays "Load error!". If I use Chrome Inspector to inspect the term "Load error!", in the Console it reports

"Failed to load resource: the server responded with a status of 404 ()"

and the link shows

"https://www.brandontennis.org/index.php/ccm/system/page/sitemap_data?displayNodePagination=0&cParentID=0&siteTreeID=0&displaySingleLevel=0&includeSystemPages=0&_=1553791901695"

Does anybody have a clue for me on how to resolve this?