Cannot Add New Blocks after upgrading to 5.6.02

Permalink
Hi All

When upgrading from C5 v5.5.2.1 to v6 I had a few problems (posted here at the forumshttp://www.concrete5.org/community/forums/installation/update-to-5.... )
I had to change the config/site.php line to 5.5.2.1 and run with that for a while. After discussing the problem in that forum topic, it became apparent that my aging theme wasn't compatible with v6, so I've recently bought the Bootstrap theme and have a CSS hack in place to keep my old theme somewhere near together while I set up Bootstrap.

My problem now is that I cannot install any new blocks. I get the following errors in the modal box instead of a list of blocks:

Warning: require_once(/home/sites/photoboffin.co.uk/public_html/packages/google_plus_one/blocks/google_plus_one/controller.php) [function.require-once]: failed to open stream: No such file or directory in /home/sites/photoboffin.co.uk/public_html/updates/concrete5.6.0.2/concrete/core/libraries/loader.php on line 205

Fatal error: require_once() [function.require]: Failed opening required '/home/sites/photoboffin.co.uk/public_html/packages/google_plus_one/blocks/google_plus_one/controller.php' (include_path='/home/sites/photoboffin.co.uk/public_html/libraries/3rdparty:/home/sites/photoboffin.co.uk/public_html/updates/concrete5.6.0.2/concrete/libraries/3rdparty:.:/usr/share/pear5') in /home/sites/photoboffin.co.uk/public_html/updates/concrete5.6.0.2/concrete/core/libraries/loader.php on line 205

These mention Google Plus One, which I don't actually use and can't get rid of. The package is still in v1 and is listed under updates available, but the update doesn't work and when I click the edit button to uninstall it, the site just returns with the add-on list page again. I also cannot find any directory for Google Plus One.

Any ideas as to a remedy?

peterfinch
View Replies: View Best Answer
hostco replied on at Permalink Best Answer Reply
hostco
Hi Pete,

Fixed.

You accidentally removed Google Plus One package from your /packages directory before uninstalling it from the concrete5 dashboard.

We uploaded Google Plus One back to /packages and you can now add blocks again as normal.

We notice you have a great deal of themes and add-ons installed that you are not using. It would be best to uninstall these from the concrete5 dashboard then manually delete the packages from the /packages directory.

Be sure to not delete any themes or add-ons that you have not already uninstalled from the concrete5 dashboard :)
peterfinch replied on at Permalink Reply
peterfinch
Hi

Thanks for all your help and support.

I'll have a clear out of the uninstalled themes and addons when I get back home on my land line broadband connection (currently on 3g in my caravan :-))

Gradely!

Pete
hostco replied on at Permalink Reply
hostco
No problem at all Pete. We are happy to assist.

Jonah
tstrudwick replied on at Permalink Reply
Hi,

It would seem I am having exactly the same problem at Pete. I am not able to add blocks and receive the same message concerning Google Plus One.

I can see it in my add-on section but am not able to remove it, upon checking my packages/ directory i cannot locate it.

What is the best way to fix this issue as i think/hope it is the cause of a lot of issues i am currently facing.

Thank you in advance.
hostco replied on at Permalink Reply
hostco
Hello,

Download Google Plus One from here.

http://www.concrete5.org/marketplace/addons/google-plus-one/...

Unzip the package and upload it to your /packages directory.

This should take care of the issue.
peterfinch replied on at Permalink Reply
peterfinch
Hi Jonah

This problem seems to be something to do with trying to uninstall or update the Google Plus One package.

When I read this latest topic update, I tried to uninstall it and I got an error message referring to something in the database. I then tried updating the package and got a message "...there was an error ...); then I couldn't add any blocks again.

The package directories identity must be being lost somehow - it's rather beyond me.

I downloaded, unzipped and added the package again, and now everything is working.

This package hasn't updated properly for months. You'd get a number "1" where the "package updated successfully" message usually appears. The same happens with Tony's File Details package. However, nothing untoward would happen whilst running 5.5.2.1; it was only after updating to v5.6 that I had problems.

Any ideas?

Pete