Cannot find installed add-ons when going to add block on a page

I am very new to Concrete5 and have searched the forums for help with this issue. I have installed one theme and 2 add-ons. I can access the theme no problem. I can see all 3 packages on the add functionality page and also from my cpanel in the /packages folder. And it says they are installed. The 2 add-ons are Google Map (Premium) and Sortable Fancybox Gallery 1.13. I have the latest Concrete5 version and am using an intel based Mac. I have cleared the cache, refreshed the page, restarted the browser, switched browsers and anything else I can think of, but when I go to add block I cannot see those 2 add-ons anywhere. What am I doing wrong???

Thank you,


View Replies:
TheRealSean replied on at Permalink Reply
Have you scrolled right down to the bottom of the list when you add a block? they are added in order so the newest ones appear right at the very bottom
Hg80Media replied on at Permalink Reply
yes right to the very bottom... they are not there
boomgraphics replied on at Permalink Reply
Hello, I had a bit of confusion once when I installed blocks. If you are installing via the marketplace (rather than downloading the package and using ftp), you need to make sure you hit install after you hit download.

There are two steps. If your new blocks are in the right side column of the "add functionality" page, you still need to install them. If they are in the left column then there is something else afoot.

EDIT. I just downloaded it via the marketplace and I had it backwards. If you apply it to your projects from, or upload it into your folder via ftp, then you will still need to install it if it is in the right column.

Installing it from the backend seems to install it with one click. I got it working that way.
Hg80Media replied on at Permalink Reply
Unfortunately the add-ons are in the left hand column. If I press edit I can uninstall them which I tried and then reinstalled to no avail. I also tried installing them by hand, but that didn't work either :(
TheRealSean replied on at Permalink Reply
and the folders/files are actually on the server?

You do have access to the database don't you?

Is anything reported in the log files
Hg80Media replied on at Permalink Reply
yes the server has the add-ons in the /packages folder, i can see them and the files are in them, i do have access to the database in the error logs there is this: [16-Jun-2011 23:49:14] PHP Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/hgme5920/public_html/concrete5/concrete/libraries/3rdparty/adodb/ on line 1411
(not that I know what that means)
Hg80Media replied on at Permalink Reply
Ok, After re-installing everything from scratch, the exact same thing happened. I would download and install an add-on - it would be in my directory and it showed in the dashboard, but when I went to press add block it still wasn't there. I then looked at my error log which would have the same thing every time I would try to re-install the add-on as I had pasted before so I knew that was the problem: set_magic_quotes_runtime() is deprecated. So..... I looked that up in the forum and found a similar question - the answer being change the above to @set_magic_quotes_runtime() - I reinstalled the add-on for the fourth time and to my utter amazement it worked!!!! So if anyone out there has the same problem, doesn't know anything about python (like me) do that and hopefully it will work :)
TheRealSean replied on at Permalink Reply
It seems the use of the set_magic_quotes could be the cause, if it is not enabled on your server?

Its been depreciated so I assume the core team have now resolved this?

The use of the @ prevents the script from falling over itself when it fails.

You may also be able to add the following to the htaccess file

ini_set('magic_quotes_runtime', 0);

grabbed from a comment on the php manual site
nomade0 replied on at Permalink Reply
Where did you make that change?

I have the exact same problem (at least the symptoms - for the cause, I'm not sure). My manually installed add-ons show up in the 'Add a Functionality' but not in the block list when I want to add one to a page. It is quite frustrating.

However, I have access to the files via FTP but that's it. No cPanel, no PhpMyAdmin, nothing else.

I tried the trick of the .htaccess, but it doesn't work:
- when I add this line to the .htaccess at the root, it blocks the entire website.
- when I add thisline to a newly created .htaccess file in the /packages directory, it doesn't help.

Does someone have a suggestion?? I would much appreciate...

Hg80meda, good that you found a solution!
nomade0 replied on at Permalink Reply
FYI, I solved my problem with this issue.

More info in this thread:
And this one