Cannot read property 'offsetWidth' of Null

Sugestions pleas

it aper in chrome (prtScrn) and (A Null) in FF after upgrade to

1 Attachment

View Replies:
adajad replied on at Permalink Reply
Could you supply a link to the c5 site ( brings up an old static html site). It would help us a lot. I would also encourage you to upgrade to v., since it has some great improvements.


Säg också till om du vill ta det här på svenska istället så kan vi ta det över PM. Jag kan inte lova att jag kan lösa problemet (då jag inte vet vad det är ännu), men jag kanske kan komma närmare problemet.
snatch71 replied on at Permalink Reply
I was really in a hurry last when I sent the question. would go away for a week.
I am now back.
Did a last resort by removing the Advanced Slider lying on the startpage.
This solved the problem temporarily.
But the website has been acting strangely since the update to will try to run in and see if it improves the stability of the page / admin actually.
I will return when testing and upgrading is completed.
SpudR replied on at Permalink Reply
I also had this error (in 5602).
In an attempt to rectify it I manually removed some things from the site but could not find the block or content showing the error (it only appears on the homepage).
I downgraded to the 5521 release, but now I cannot edit the homepage - I just get a blank page when I log in.

The URL for the homepage once I log in seems to just be the standard ( without any of the usual code behind it.

Any ideas?

Slight addition to this - I can get in to edit the pages if I use Internet Explorer in compatibility mode, but Chrome still shows a blank page. The OffSetWidth error is still there though...
snatch71 replied on at Permalink Reply
Do you have Advanced Slider installed on your site?
If! try to remove it from where it is and it maybe will temporarily fix the buggy stuff.

And do you have any extra code in your index.php page. try use a clean index.php with just


It solved one problem but gave me another that don't apply here
SpudR replied on at Permalink Reply
I do have 'Power slider lite', not 'Advanced slider'

Removing power slider doesn't seem to help though...
jamietelin replied on at Permalink Reply
Same problem discussed here:

I am having same problem. I have no idea why or how to fix it. I run nothing strange. I have no downloaded plugins. I only have one homemade theme, and that seem to work. I get the error even if I uninstall that theme, I've tried that just in case.

I only get the error in the Dashboard. But everything seems to work fine.

I tried to remove and re-install Concrete5. But then all of a sudden the error gets back again. For no apparent reason.

Searching the source code for "offesetWidth" i find 49 instances of it, all in Concrete5 "core". Example in; bootstrap.js, bootstrap.tooltip.js, jquery.js, tiny:mce.js and so on...
adajad replied on at Permalink Reply
After further investigation I have found that the problem with offsetWidth of Null (or 'a is null') comes from not having a set width on the parent div.

Have a look in your markup and set a width to your div and see if that solves your problem.
jamietelin replied on at Permalink Reply
But this occurs in Dashboard only. And I haven't edited Dashboard.
Also.. after some trail and error, I managed to get rid of the error by removing the default Google Maps block used on my site. How can this affect the Dashboard?
tallacman replied on at Permalink Reply
I had this problem and found removing the map eliminated the error.
JohntheFish replied on at Permalink Reply
A generic solution for this script problem is in

I have a pull request on c5 Github to fix it for the standard maps block.

An alternative solution is to Ajax load the problem block after the containing element is visible (and hence has a size) or an Ajax loaded stack containing the block. This can be done for most blocks using Blocks by Ajax.
JohntheFish replied on at Permalink Reply
This problem occurs when a map is in a global area. The hidden initialisation bug crops up on any page. The fix is on github at: