Can't install - strange error

Permalink
hi there, anybody know what's happening there? I get this error when trying to install C5:

"Unable to install database: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?.

Trace:
#0 /var/www/html/c5/concrete/src/Package/StartingPointPackage.php(181): Concrete\Core\Package\StartingPointPackage->install_database() #1 /var/www/html/c5/concrete/controllers/install.php(397): Concrete\Core\Package\StartingPointPackage->executeInstallRoutine('install_databas...') #2 [internal function]: Concrete\Controller\Install->run_routine('elemental_blank', 'install_databas...') #3 /var/www/html/c5/concrete/src/Controller/AbstractController.php(294): call_user_func_array(Array, Array) #4 /var/www/html/c5/concrete/src/Routing/ControllerRouteCallback.php(27): Concrete\Core\Controller\AbstractController->runAction('run_routine', Array) #5 /var/www/html/c5/concrete/src/Routing/Router.php(149): Concrete\Core\Routing\ControllerRouteCallback->execute(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Routing\Route), Array) #6 /var/www/html/c5/concrete/src/Http/DefaultDispatcher.php(121): Concrete\Core\Routing\Router->execute(Object(Concrete\Core\Routing\Route), Array) #7 /var/www/html/c5/concrete/src/Http/DefaultDispatcher.php(57): Concrete\Core\Http\DefaultDispatcher->handleDispatch(Object(Concrete\Core\Http\Request)) #8 /var/www/html/c5/concrete/src/Http/Middleware/DispatcherDelegate.php(39): Concrete\Core\Http\DefaultDispatcher->dispatch(Object(Concrete\Core\Http\Request)) #9 /var/www/html/c5/concrete/src/Http/Middleware/ThumbnailMiddleware.php(71): Concrete\Core\Http\Middleware\DispatcherDelegate->next(Object(Concrete\Core\Http\Request)) #10 /var/www/html/c5/concrete/src/Http/Middleware/MiddlewareDelegate.php(38): Concrete\Core\Http\Middleware\ThumbnailMiddleware->process(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Http\Middleware\DispatcherDelegate)) #11 /var/www/html/c5/concrete/src/Http/Middleware/FrameOptionsMiddleware.php(39): Concrete\Core\Http\Middleware\MiddlewareDelegate->next(Object(Concrete\Core\Http\Request)) #12 /var/www/html/c5/concrete/src/Http/Middleware/MiddlewareDelegate.php(38): Concrete\Core\Http\Middleware\FrameOptionsMiddleware->process(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Http\Middleware\MiddlewareDelegate)) #13 /var/www/html/c5/concrete/src/Http/Middleware/CookieMiddleware.php(37): Concrete\Core\Http\Middleware\MiddlewareDelegate->next(Object(Concrete\Core\Http\Request)) #14 /var/www/html/c5/concrete/src/Http/Middleware/MiddlewareDelegate.php(38): Concrete\Core\Http\Middleware\CookieMiddleware->process(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Http\Middleware\MiddlewareDelegate)) #15 /var/www/html/c5/concrete/src/Http/Middleware/ApplicationMiddleware.php(29): Concrete\Core\Http\Middleware\MiddlewareDelegate->next(Object(Concrete\Core\Http\Request)) #16 /var/www/html/c5/concrete/src/Http/Middleware/MiddlewareDelegate.php(38): Concrete\Core\Http\Middleware\ApplicationMiddleware->process(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Http\Middleware\MiddlewareDelegate)) #17 /var/www/html/c5/concrete/src/Http/Middleware/MiddlewareStack.php(86): Concrete\Core\Http\Middleware\MiddlewareDelegate->next(Object(Concrete\Core\Http\Request)) #18 /var/www/html/c5/concrete/src/Http/DefaultServer.php(85): Concrete\Core\Http\Middleware\MiddlewareStack->process(Object(Concrete\Core\Http\Request)) #19 /var/www/html/c5/concrete/src/Foundation/Runtime/Run/DefaultRunner.php(119): Concrete\Core\Http\DefaultServer->handleRequest(Object(Concrete\Core\Http\Request)) #20 /var/www/html/c5/concrete/src/Foundation/Runtime/DefaultRuntime.php(102): Concrete\Core\Foundation\Runtime\Run\DefaultRunner->run() #21 /var/www/html/c5/concrete/dispatcher.php(36): Concrete\Core\Foundation\Runtime\DefaultRuntime->run() #22 /var/www/html/c5/index.php(3): require('/var/www/html/c...') #23 {main}
An error occurred."

Never seen anything like this before ... stuck

rritz
View Replies:
mlocati replied on at Permalink Reply
mlocati
What concrete5 version are you trying to install? Which PHP version? Are you installing concrete5 by downloading it from concrete5.org or by using Composer?
rritz replied on at Permalink Reply
rritz
I was trying to install 8.4.2
I have a website using this version, and it's gone completely kaputt, so I tried to reinstall ...
php 7.3.4

I fetched the zip file from concrete5 site using wget via SSH
mlocati replied on at Permalink Reply
mlocati
concrete5 8.4.2 doesn't support PHP 7.3: you should use a newer concrete5 version (8.5.2), or an older PHP version (7.2 or 7.1)