"Checking for Updates" - Constantly and can't edit my site.

Permalink 5 users found helpful
First time poster on here and very much a beginner user of C5 so please go easy on me.

I run a website just to showcase my pictures. When I logged in last week I made the mistake of updating to the latest version. Cue loads of tension and anger now because when I log into my website I get the site greyed out as it says it is 'Checking for Updates'. I can't get around it or stop it.

Any suggestions on how to get around this or to remove the initial check when logging in would be great.

View Replies: View Best Answer
chriscyner replied on at Permalink Reply
Can anyone help?
Do you need more information?
thephilm replied on at Permalink Reply
thephilm
Chris,
I had something similar on my end but it was while viewing from a mobile (I was checking how well it would edit)
It went away after I cleared my cache, and my cookies. This was right after upgrading to 5.5.
- Phil
chriscyner replied on at Permalink Reply
Hi Phil,

Thanks for the response. I've just tried that (with Chrome, Opera, IE and Firefox) and I'm stuck with the same issue.

I read about white list entries for site.php earlier today. Is there a complete set of them available (maybe one that stops the CMS from phoning home looking for updates)?

Cheers,
Chris
frz replied on at Permalink Reply
frz
Just to clarify as we try to debug this..

The intended behavior is....

If you login with a user who is in the administrator group, once every 24 hours you will see the newsflow overlay. The "checking for updated" spinny thing is what you see before that. So it's not re-breaking every 24 hours, it's just trying to do what it wants to do.

So the questions really is Does it ever stop loading and display the newsflow UI? If not, can you connect to the community or are you just behind a firewall?
spencerhudson replied on at Permalink Reply
spencerhudson
spencerhudson replied on at Permalink Best Answer Reply
spencerhudson
I've applied these and the "checking for updates" has stopped:

/config/site.php
define('ENABLE_MARKETPLACE_SUPPORT', false);
define('ENABLE_NEWSFLOW_OVERLAY', false);

interesting to see if this works for others.
chriscyner replied on at Permalink Reply
Spencer,

Thanks for taking the time to look this up for me. I've moved back a version to get my website editable again but I've got the new version running in a sandpit. I'll let you know how it goes when I make the changes.

Thanks again,
Chris
johnson72223 replied on at Permalink Reply
In the /default/site.php

insert this in lines 9 and 10...or last two lines...

define('DIR_REL', '');
define('ENABLE_NEWSFLOW_OVERLAY', false);


this has worked for me.
mwhitecar replied on at Permalink Reply
mwhitecar
Thanks Spenser. I tried adding these to definitions to my site.php and the problem stopped.
spencerhudson replied on at Permalink Reply
spencerhudson
lehr provided this block of code - insert this into your /elements/header.php if you've got one ... and only the ADMIN user will see get the "checking for updates" if there are any! Seems to work a treat. Thanks again lher

<?php
$u = new User();
if($u->uID > 1)
$u->saveConfig('NEWSFLOW_LAST_VIEWED', time() + (24 * 60 * 60));
?>
mdmltd replied on at Permalink Reply
Thanks for the help.
I had the same problem with the spinny thing after updating from 5.4.2.2 to 5.5.1. Obviously there is a bug in there somewhere at the moment.

Applying these to the site.php made my site work again.

define('ENABLE_MARKETPLACE_SUPPORT', false);
define('ENABLE_NEWSFLOW_OVERLAY', false);
wwwdesign replied on at Permalink Reply
Sorry spencer, but the code for
/config/site.php
define('ENABLE_MARKETPLACE_SUPPORT', false); 
define('ENABLE_NEWSFLOW_OVERLAY', false);


works as a temp fix, it doesn't solve the issue of the Checking for Updates spinner being stuck while in maintenance mode. Because even if add the code, refresh the site and comment the code out, it is still stuck...

The only work around I found is to add that code, take the site out of maintenance mode and refresh the site so it checks for the update then remove the code so you can work in maintenance mode again...

We need to check what is written for when the site is NOT in maintenance mode that makes checking for updates work, so we can compare the maintenance mode code and make changes to FIX the issue...

Or, I guess we can deal with the issue until C5 core team fixes the issue. Either way, if I find a fix, I'll let everyone know :)
CoroNacionalPR replied on at Permalink Reply
CoroNacionalPR
It worked for me! :)
Legz replied on at Permalink Reply
can you please help ... i have the same error after updating to latest version of concrete & now checking for updates is stuck on screen when i try to go to dashboard & i have no idea how to edit or access my php etc
Erik74 replied on at Permalink Reply
I had the same problems but discovered that it was only when I was in maintenance mode the news window froze.
hissy replied on at Permalink Reply
hissy
I had the same problem, and I found the cause of problem.
In maintenance mode, /dashboard/home page will displayed in maintenance mode. Usually, admin pages are displayed normally under in maintenance mode. But, /dashboard/home page returns isAdminArea() false, so Newsflow doesn't appear in maintenance mode. To solve the problem, override the Page::isAdminArea with like this:

public function isAdminArea() {
   $pos = strpos($this->cPath, "/" . DIRNAME_DASHBOARD);
   return ($pos > -1);
}


But I think there are more better solutions.
koodlaty replied on at Permalink Reply
koodlaty
Same problem here. It is pretty annoying.

Spencerhudsons solution is working for me as well but it is just a workaround - site is disconnected from the community.

Does any one know what to do?
MVS replied on at Permalink Reply
I had the same problem in maintenance mode after updating from 5.4.2.2 to 5.5.1 with the Admin-Login. The "checking for updates" Popup runs and runs but nothing happenend and the editing of the site was impossible.

I stopped it with the workaround from spencerhudson (Thanks for that). But it seems to be a bug and a solution is needed :-)
eubanksto replied on at Permalink Reply
eubanksto
I just wanted to keep this thread active. I am also having this problem and I guess cPanel's quick install is installing the version with the bug. I guess I'll add the script, update, then remove the script because I don't want to never see the update screen again.
wwwdesign replied on at Permalink Reply
So I'm having the same issue, even with the most recent update 5.5.2.1. While in maintenance mode, checking for updates gets stuck, however, when you are not in maintenance mode, checking for updates works...

Where are the files that control checking for updates while in maintenance mode and under normal site operation so I can run a comparison and try to get a FIX.

In my opinion, if the Dashboard already has a link for Admin to use to check for updates, then it should be up to the site Admin to do so, not the website software.. (Unnecessary resources being used IMO)

Also, perhaps an option in the dashboard to have the site automatically check for updates or manually check for them as a Global setting. Just some input for the next version.
vytautas replied on at Permalink Reply
I had the same problem as well, now this morning i enter maintenance mode,check for updates and it ran very smooth. I downloaded the mosr current 5.5.2.1 and updated it as requested on the screen. i then choose back to website and it shows the site is down for maintenance. Thinking this is no big deal i relogged as the admin and to my surprise, i cant get a tool bar to get out of maintenance mode. Any help would be appreciated.

Don
ddauwg replied on at Permalink Reply
msouden replied on at Permalink Reply
msouden
Was there never a more permanent fix for this bug? I just disabled the news feed, but that's a heckuva (bad) workaround.

Tying together updates, newsfeeds, and community stuff isn't exactly confidence-inspiring either, let alone that this rather bad bug is coming up on its first birthday.
siteadvice replied on at Permalink Reply
siteadvice
I added define('ENABLE_NEWSFLOW_OVERLAY', false); to site.php and that's a good fix but as msouden points out, it's a workaround that probably shouldn't have to be done.

Incidentally, I discovered this problem when I had to change the domain's BASE_URL because the site's parent company had changed its name and re-branded.
siteadvice replied on at Permalink Reply
siteadvice
I added define('ENABLE_NEWSFLOW_OVERLAY', false); to site.php and that's a good fix but as msouden points out, it's a workaround that probably shouldn't have to be done.

Incidentally, I discovered this problem when I had to change the domain's BASE_URL because the site's parent company had changed its name and re-branded.
zoinks replied on at Permalink Reply
Yup... surprised to see this problem reappear for me all of a sudden in 2014 with the latest and greatest Concrete5. Certainly a bug that should be fixed as it renders the update and news features useless.

For now, I just "tricked it" by going to /login instead of /dashboard and then I went into dashboard. Somehow that stopped the infinite spin. If it happens again, I'll have to get rid of the update & overlay again.
fcgleason replied on at Permalink Reply
fcgleason
I think I am having this problem now on an update to 5.6.0.
URL, enter "Checking Updates" then it disapppears and the screen turns grey and I am locked out from dashboard. This happens when I go to the login page too.

Why is it doing this? I never asked it to.