Concrete requires GD library 2.0.1 or greater issue2 users found helpful
I'm now trying to install Concrete5 on a Server running CentOS 5.5 with cPanel installed. My PHP version is 5.2.9
But when I try I get a message that "Concrete requires GD library 2.0.1 or greater"... I have tried to install the packed, but when I do I get this message:
Setting up Install Process
Package gd-2.0.33-9.4.el5_4.2.x86_64 already installed and latest version
Nothing to do
So does anyone know what else can be wissing and causing this issue - I'm a unix Newbee,
I have attached the warning from the install screen
PS! Sorry I think I by accident clicked the heart instead of the "reply" btn...
Do you want to see it ?
to the compile script
do a search for gd on mine for example:http://mnkras.com/phpinfo.php
How do I install gd on Linux?
Well, what do you really want?
If you want gd for a PHP application, just do (for Fedora):
yum install php-gd
Or, for Red Hat Enterprise Linux or CentOS:
I was missing and all is fine now ;-)
Nice to see a forum that works.
I had GD 2.0.35 and still I got the complaint about GD 2.0.1 or higher.
I searched on Google with no luck. A search on "GD" or "gd" in these forums turned up nothing.
I think it was a search on "library" that discovered this thread. So it turns out I needed to rebuild php. Aha!
I used the following web page to quickly test whether I got php correctly built and installed in apache:
<?php imagecreatetruecolor(100,100); phpinfo(); ?>
I think the complaint from concrete5 should be less cryptic. It could say "Concrete requires that PHP be built with GD 2.0.1 or higher."
First, I installed gd using homebrew by simply typing
brew install gd
in my console
Then then followed the instruction to install a better version of PHP via homebrew as provided by @Jpsy here:http://stackoverflow.com/questions/26493762/yosemite-php-gd-mcrypt-...
Hope this helps all the people on Mac out there.