Concrete requires GD library 2.0.1 or greater issue

Permalink 2 users found helpful
I have been searching the forum and google regarding help on this issue, but to be honest I don't really get what is wrong. Hope someone can guide me here.

I'm now trying to install Concrete5 on a Server running CentOS 5.5 with cPanel installed. My PHP version is 5.2.9

But when I try I get a message that "Concrete requires GD library 2.0.1 or greater"... I have tried to install the packed, but when I do I get this message:

Setting up Install Process
Package gd-2.0.33-9.4.el5_4.2.x86_64 already installed and latest version
Nothing to do
Install Complete

So does anyone know what else can be wissing and causing this issue - I'm a unix Newbee,

I have attached the warning from the install screen

// Brian

1 Attachment

View Replies: View Best Answer
Mnkras replied on at Permalink Reply
can you show us a phpinfo();
Brian1961 replied on at Permalink Reply
Sure I can

PS! Sorry I think I by accident clicked the heart instead of the "reply" btn...

// Brian
andrew replied on at Permalink Reply
We test this by verifying that the PHP function "imagecreatetruecolor" exists. It's possible I believe to have GD installed but not enable it in php.ini - or perhaps not have all of its options enabled? Maybe libPNG or something like that isn't enabled?
Brian1961 replied on at Permalink Reply
Ok... I have look using phpinfo(); but I don't know what to look for here ? Searhed for GD but found nothing...

Do you want to see it ?
Mnkras replied on at Permalink Best Answer Reply
your php wasn't compiled with GD enabled,

try adding

to the compile script

do a search for gd on mine for example:
nteaviation replied on at Permalink Reply
Rather than recompile php, you can just add it as a plugin module using yum or up2date. I think yum works on the newer CentOS's. See:

How do I install gd on Linux?
Well, what do you really want?
If you want gd for a PHP application, just do (for Fedora):

yum install php-gd

Or, for Red Hat Enterprise Linux or CentOS:
up2date php-gd
Brian1961 replied on at Permalink Reply
Thank too all for you input...

I was missing and all is fine now ;-)

Nice to see a forum that works.
thewisper replied on at Permalink Reply
Man! This is a real gotcha!

I had GD 2.0.35 and still I got the complaint about GD 2.0.1 or higher.

I searched on Google with no luck. A search on "GD" or "gd" in these forums turned up nothing.

I think it was a search on "library" that discovered this thread. So it turns out I needed to rebuild php. Aha!

I used the following web page to quickly test whether I got php correctly built and installed in apache:
<?php imagecreatetruecolor(100,100); phpinfo(); ?>

I think the complaint from concrete5 should be less cryptic. It could say "Concrete requires that PHP be built with GD 2.0.1 or higher."
nerdess replied on at Permalink Reply
I had a similar issue when working locally on Yosemite. The build-in PHP apparently does not come with PNG/Freetype support. This is what I did to fix it:

First, I installed gd using homebrew by simply typing

brew install gd

in my console

Then then followed the instruction to install a better version of PHP via homebrew as provided by @Jpsy here:

Hope this helps all the people on Mac out there.