Concrete5 "Broke" after updating PHP / Apache to include a few additional mods (GD, TTF, ETC)

Permalink
Here's the problem / errors:

Strict Standards: Non-static method Cache::get() should not be called statically in /home/ebridal/public_html/v1/concrete/models/package.php on line 84

Strict Standards: Non-static method Cache::key() should not be called statically in /home/ebridal/public_html/v1/concrete/libraries/cache.php on line 117

Strict Standards: Non-static method Cache::getLibrary() should not be called statically in /home/ebridal/public_html/v1/concrete/libraries/cache.php on line 122

Strict Standards: Non-static method Loader::package() should not be called statically in /home/ebridal/public_html/v1/concrete/startup/packages.php on line 8

Strict Standards: Non-static method Object::camelcase() should not be called statically in /home/ebridal/public_html/v1/concrete/libraries/loader.php on line 290

Strict Standards: Non-static method User::checkUserForeverCookie() should not be called statically in /home/ebridal/public_html/v1/concrete/startup/user.php on line 4

Strict Standards: Non-static method Config::get() should not be called statically in /home/ebridal/public_html/v1/concrete/startup/maintenance_mode_check.php on line 5

Here's my phpinfo file:http://www.ebridalsuite.com/index.php...
Here's my site:http://www.ebridalsuite.com/v1/...

I've tried recompiling and reinstalling both Apache and PHP to no avail.. Also, I tried a "basic" installation of both and nothing worked either.

Thanks for your help!

View Replies:
SheldonB replied on at Permalink Reply
SheldonB
you have to turn strick standards off

just copied this from google don't know if it works



In your php.ini change

error_reporting = E_ALL

to

error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT

or

error_reporting = ~E_ALL
platinumn23 replied on at Permalink Reply
I have this set in my php.ini file:

error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT

and still get the same problems / errors.
SheldonB replied on at Permalink Reply
SheldonB
http://www.concrete5.org/community/forums/customizing_c5/strict-standards-on-shred-hosting-cant-edit-php.ini/

http://www.concrete5.org/community/forums/installation/strict-stand...

that should be it

if you search for strick standards error you can find a number of post with the same issues
neotral replied on at Permalink Reply
Hi all,

I have the same issue and my host will not allow a php.ini file. Is there another way of rectifying this issue?

thanks
Peter
JohntheFish replied on at Permalink Reply
JohntheFish
There may be a setting in your hosts control panel that does the equivalent. You need to talk to their technical support.
Korvin replied on at Permalink Reply
Korvin
edward replied on at Permalink Reply
Thanks! Applying this to an (ancient) C5 install solved my problem.