Concrete5 Installation with xampp

Permalink 5 users found helpful
hey you guys itried to instal concrete5 with xampp but i get this report:

Strict Standards: Non-static method Loader::database() should not be called statically in C:\xampp\htdocs\concrete\concrete\dispatcher.php on line 23
Strict Standards: Non-static method Loader::library() should not be called statically in C:\xampp\htdocs\concrete\concrete\libraries\loader.php on line 166
Strict Standards: Non-static method Loader::library() should not be called statically in C:\xampp\htdocs\concrete\concrete\libraries\loader.php on line 167
Strict Standards: Non-static method Loader::library() should not be called statically in C:\xampp\htdocs\concrete\concrete\libraries\loader.php on line 168
Strict Standards: Non-static method Loader::library() should not be called statically in C:\xampp\htdocs\concrete\concrete\libraries\loader.php on line 169
Strict Standards: Declaration of dbTable::create() should be compatible with that of dbObject::create() in C:\xampp\htdocs\concrete\concrete\libraries\3rdparty\adodb\adodb-xmlschema03.inc.php on line 642
Strict Standards: Declaration of dbIndex::create() should be compatible with that of dbObject::create() in C:\xampp\htdocs\concrete\concrete\libraries\3rdparty\adodb\adodb-xmlschema03.inc.php on line 806
Strict Standards: Declaration of dbData::create() should be compatible with that of dbObject::create() in C:\xampp\htdocs\concrete\concrete\libraries\3rdparty\adodb\adodb-xmlschema03.inc.php on line 1051
Strict Standards: Declaration of dbQuerySet::create() should be compatible with that of dbObject::create() in C:\xampp\htdocs\concrete\concrete\libraries\3rdparty\adodb\adodb-xmlschema03.inc.php on line 1302
Strict Standards: Non-static method Loader::library() should not be called statically in C:\xampp\htdocs\concrete\concrete\libraries\loader.php on line 170
Strict Standards: Non-static method Loader::library() should not be called statically in C:\xampp\htdocs\concrete\concrete\dispatcher.php on line 26
Strict Standards: Non-static method Cache::startup() should not be called statically in C:\xampp\htdocs\concrete\concrete\dispatcher.php on line 27
Strict Standards: Non-static method Cache::getLibrary() should not be called statically in C:\xampp\htdocs\concrete\concrete\libraries\cache.php on line 59
Strict Standards: Non-static method Loader::library() should not be called statically in C:\xampp\htdocs\concrete\concrete\libraries\cache.php on line 28
Strict Standards: Non-static method Loader::library() should not be called statically in C:\xampp\htdocs\concrete\concrete\dispatcher.php on line 30




followed by

Support for C5 Request URLs
Concrete cannot parse the PATH_INFO or ORIG_PATH_INFO information provided by your server.



i hope someone can help me :)

View Replies: View Best Answer
madeforspace replied on at Permalink Best Answer Reply
madeforspace
Are you using 1.7.4 XAMPP or XAMPP lite?
I think its the first.
If it is the you need to replace a line in your file C:\xampp\php\php.ini
error_reporting = E_ALL | E_STRICT --> error_reporting = E_ALL & ~(E_NOTICE | E_STRICT | E_DEPRECATED)

That should sort it out for you.
If not and you can get XAMPP lite 1.7.3 then all should work ok without a code change.

Hope that helps
easytiger replied on at Permalink Reply
thank you so much ! it works
madeforspace replied on at Permalink Reply
madeforspace
Cool, have lots of C5 fun.
madesimplemedia replied on at Permalink Reply
madesimplemedia
Hi I'm using xampp 1.7.4 and trying to get this to work locally on Windows 7 with no joy. I made the change you mentioned and I still have that error - any more ideas?
madesimplemedia replied on at Permalink Reply
madesimplemedia
Ignore me, restarting seems to have sorted it thanks a lot!!
satyajit replied on at Permalink Reply
Thanks. good solution. It is working.
BrandiLinn replied on at Permalink Reply
I don't know what that did, but of the threads I went through, that was the simplest answer, and it worked (after I restarted XAMPP, which I'd not have thought to do had others not mentioned it...).

So, while I'm not the original asker: thanks!
madeforspace replied on at Permalink Reply
madeforspace
My pleasure :)

It's an old post but I am glad it is still useful.
Durator replied on at Permalink Reply
Durator
It still is the best tip to get Concrete5 installation with XAMPP under Windows to work when you get the error "Concrete cannot parse ..."
It works like a charm!
LilaLola replied on at Permalink Reply
LilaLola
Hi Alex:

Thank you for your answer, that's exactly my problem, too.

I need to know where exactly I need to put your line of code or what to replace.

The syntax in my php.ini looks like this:
; error_reporting
; Default Value: E_ALL & ~E_NOTICE
; Development Value: E_ALL | E_STRICT
; Production Value: E_ALL & ~E_DEPRECATED

Is the above what I am supposed to replace with your line of code?
Here is what I tried; pasting your line of code under the above, saved the file, restarted XAMPP and reloaded the localhost to no avail.

Any help would be greatly appreciated.
Thank you!
Barbara
LilaLola replied on at Permalink Reply
LilaLola
Thank you very much, madeforspace/Alex - it worked beautifully :)
Barbara
madeforspace replied on at Permalink Reply
madeforspace
You're welcome Barbara.

In case anyone had a similar situation the location of the code in the php.ini can be found in the section marked Error Handling & Logging.
royall replied on at Permalink Reply
I added the following to my .htaccess
It worked great for me.

# error_reporting to E_ALL|E_STRICT
php_value error_reporting "6143"
php_value display_errors "1"
slojes replied on at Permalink Reply
slojes
This is an old post, but I am having the same issue. I have made the changes in the php.ini file, rebooted but the problem persists. Here is part of my php.ini file:

display_errors
; Default Value: Off
; Development Value: On
; Production Value: Off

; display_startup_errors
; Default Value: Off
; Development Value: On
; Production Value: Off

; error_reporting = E_ALL & ~E_DEPRECATED
; Default Value: E_ALL & ~E_NOTICE
; Development Value: E_ALL | E_STRICT
; Production Value: E_ALL & ~E_DEPRECATED

Is there anything wrong there? Any other ideas?
LilaLola replied on at Permalink Reply
LilaLola
Hi John:

Happy New Year from Chicago!

Anyway, what worked for me was to replace the entire line of error_reporting (you have right now:
";error_reporting = E_ALL & ~E_DEPRECATED")

with the following string of code:

;error_reporting = E_ALL & ~(E_NOTICE | E_STRICT | E_DEPRECATED)

Save the file and start your server.

This'll get rid of the warnings and you'll be able to get to the C5 Installation Screen.

Good Luck!
LL
slojes replied on at Permalink Reply
slojes
I wish that had worked, but unfortunately I get the same long string of Strict Standards....messages.
Thanks anyway.
John
Phallanx replied on at Permalink Reply
Phallanx
N.B. A semicolon at the beginning of the line means it is commented out.

Around line 516 (section "Error handling and logging") you should see
error_reporting = E_ALL | E_STRICT


Make sure it is
error_reporting = E_ALL & ~E_DEPRECATED

Make sure also there is not a semicolon before the statement.
slojes replied on at Permalink Reply
slojes
Thank you Phallanx,
That did it. I don't know how the fixes above (which included the semicolon and thus are just comments in the php file) worked for the other people...maybe they were smarter than me and knew to find the code without the semicolon to replace.
Anyway, thank you so much for providing the answer I needed!!!
-John
fastcrash replied on at Permalink Reply
fastcrash
if you do not have access to php.ini or this setting just for c5
use php function
// Turn off all error reporting
error_reporting(0);
// Report simple running errors
error_reporting(E_ERROR | E_WARNING | E_PARSE);


see php manual
Wayne2020 replied on at Permalink Reply
Thanks for this, it worked for me as well whereas the solution mentioned at beginning of thread did not. Thanks again.