concrete5 on xampp install problem

Permalink
Hi,
i'm trying to install concrete5 on Xampp; i installed xampp in c:/xampp, started MySQL and Apache. I have access to the xampp web interface (localhost/xampp), and i created the DB for concrete5.
I unzipped concrete 5 in c:/xampp/concrete.
My problem is that i can not access the concrete5 web interface (http://localhost/concrete), i receive an error messsage, saying that the page does not exist.
Any suggection is welcome...

Thanks

nicolas

View Replies:
MAXXSERVERS replied on at Permalink Reply
I know it sounds trivial but I have had to actually use the full URL At times.

/localhost/concrete/index.php etc.

Not a huge help I know - But honestly the only other thing I would suggest is making sure xamp is running and make sure apache is running etc.
AndyJ replied on at Permalink Reply
pretty much the same as above - add the trailing slash

http://localhost/concrete/
AndyJ replied on at Permalink Reply
just re-read:

when I've used xampp I've put my websites inside

c:\xampp\htdocs\
nico741019 replied on at Permalink Reply
Thanks, i did follow a procedure from a book, they say that it's more practical not to put concrete5 in htdocs if we want to work on several projects at a time, but i don't know why.
Anyway, i have another problem, i can not access anymore tohttp://localhost/xampp, but well tohttp://127.0.0.1/xampp (and the file c:/windows/system32/etc/hosts contains 127.0.0.1 localhost).
But when i tryhttp://127.0.0.1/concrete orhttp://127.0.0.1/concrete/index.php,... it does not work neither...
I checked my services, i have 2 Apache httpd processes, and 1 mysqld process.
Thanks for your help...

nicolas
AndyJ replied on at Permalink Reply
what happnes if you shut down xampp, restart your pc and then start it up again.

Is very difficult to say as it sounds as though you may have made some changes...

If you haven't done too much work and it still doesn't work after a restart etc it might be worthwile uninstalling and reinstalling again.

What Operating System are you using by the way and what firewall(s) do you have on your system?
nico741019 replied on at Permalink Reply
I reinstalled everything on another Win7 pc, created the db, changed the error parameter and the mysql.ini file, and started apache and mysql; the localhost problem is solved, but i still can not access concrete5 (http://localhost/concrete5 orhttp://localhost/concrete5/index.php).... I also copied the concrete5 folder in the directory that you mentioned, and rename it to "concrete5", but it does not change anything. I must be doin something wrong, but i don't know what. But thanks for your support!

nicolas
adamjohnson replied on at Permalink Reply
adamjohnson
You should also take a look at this article if you plan to move onto a real server later:

http://adamjohnsondesign.com/blog/working-with-concrete5-and-window...

Sounds like you are doing most things right. Check out Remo's book for step by step instructions.
nico741019 replied on at Permalink Reply
Hello,
this is the book i use to install it, but i just can't access thehttp://localhost/concrete5 page, i tried to install the package on another pc and i have the same result. Is there another way of installing concrete5? I found some scripts, but not supported on windows.
Thanks.

nicolas
adamjohnson replied on at Permalink Reply
adamjohnson
What about via simplescrips via your website hosting? That should be a 1 click install via cpanel or plesk. You can even install it on a subdomain.
nico741019 replied on at Permalink Reply
Well i'm trying to install it locally, on my pc. Apache and Mysql are ok, but the only procedure i have to install concrete5 is to access it through the localhost address, but it does not work...
Thanks

nicolas
nico741019 replied on at Permalink Reply
After reinstalling it in htdocs, everything is ok now, many thanks all for your help.

nicolas
sambrody24 replied on at Permalink Reply
sambrody24
If you are using windows 7, I would suggest WAMP instead of xampp, easier interface, everything goes in one root folder and can be accessed through local host