Connect to Community

Permalink
I have a Concrete5 driven website onhttp://motettkor.no which is hosted on a webserverhttp://dittdomene.no

The initial setup on the webserver was on a test environment, which I later moved to the production environment. Also I deleted the test project(s) from the community.

Now I have trouble connecting the production site to the Concrete5 Community:

when I login to the site and choose Dasboard, Extend concrete5, I receive message ¨Error establishing connection to the concrete5 community. Please check that curl and other required libraries are enabled. ¨. On this page I subsequently press Re-connect to Community

when I Re-connect to Community I receive message ¨Unable to generate a marketplace token. Please ensure that allow_url_fopen is turned on, or that cURL is enabled on your server. If these are both true, It's possible your site's IP address may be blacklisted for some reason on our server. Please ask your webhost what your site's outgoing cURL request IP address is, and email it to us at [email protected]¨

I ran script curl_check.php on the webserve to establish url_fopen and cURL setting. Reading from the output (attached phpinfo.odt), directive ¨allow_url_fopen¨ is on and curl is enabled. Aslo I presume that the outgoing cURL request IP address is 91.207.158.161 (reading from SERVER_ADDR in environment, but of this I am not sure it is the IP address you require)

I have sent a message to [email protected] beginning of march to which there became no reply. Any one on the form can I help me resolv this matter maybe?

1 Attachment

lvbaal
View Replies: View Best Answer
StefSmeers replied on at Permalink Reply
StefSmeers
Go to the database then open the table called "Config".
Empty the column "configValue" in the rows where the configItems are "marketplace.token" and "marketplace.url_token".
Now you should be able to reconnect again.

If there are still any questions, feel free to ask!

- Stef
lvbaal replied on at Permalink Reply 1 Attachment
lvbaal
I did that already after having found this method in the forum, but without success. There are three rows remaining in config table, see attachement.
Any further suggestions maybe?
lvbaal replied on at Permalink Best Answer Reply
lvbaal
oops, now I see that I deleted the rows in stead of emptying the columns. I'l correct this mistake and try again...
lvbaal replied on at Permalink Reply
lvbaal
I inserted the rows where the configItems are "marketplace.token" and "marketplace.url_token" with empy ConfigValue and tried to re-connect. Same error...
StefSmeers replied on at Permalink Reply
StefSmeers
I don't know for sure. In this case it would be easier to have a look at it myself via Teamviewer or join.me.
If you agree?

- Stef
lvbaal replied on at Permalink Reply
lvbaal
Agreed. I'm setting up join.me now...
lvbaal replied on at Permalink Reply
lvbaal
Please inform me how to forward the join.me code to you
StefSmeers replied on at Permalink Reply
StefSmeers
You can send me a private message with the link.
lvbaal replied on at Permalink Reply
lvbaal
PM send
geniewish replied on at Permalink Reply
geniewish
I have a similar issue with a website: when I click on the link to connect to the project page it just goes to my login; when I go to list all my projects it is no longer in there. Can you help?
lvbaal replied on at Permalink Reply
lvbaal
Hi,
StefSmeers looked into my cofiguration and tried out some things, but did not succeed in overcoming the Re-connect issue on my site unfortunately.

I still need help with this.
patej replied on at Permalink Reply
patej
Hi,
This might be too late for you, lvbaal, but I encountered the same issue with my 5.7.5 install and this thread was one of the few which came up, so I'll post my solution here hoping it helps someone..

In my case the issue was resolved by changing the timeout value of a function using cURL. Concrete5 support directed me to a bug report by jxn (https://github.com/concrete5/concrete5/issues/2934... ) which explained the problem and provided a solution in commit https://github.com/jxn/concrete5/commit/f19a2617b0e02d07f3eec75a752c... In brief, you can get by the problem by
changing line 305 in file /concrete/src/File/Service/File.php
from
public function getContents($file, $timeout = 5)
to
public function getContents($file, $timeout = 15)
(in my case 15 was enough, e.g. 10 wasn't)
Naturally you can also make the full change suggested by jxn to make it configurable in app/config.php, too.

Hope this helps.
--patrik