Constant Sign-In or Logging me out issue

Permalink 3 users found helpful
I've installed the latest version and I believe I've given all the directories and files the correct permissions. Everytime I try to sign in to edit or go to the dashboard I'll click sign in after entering my username and password and the page will ask me to sign in again. No error, almost like the page just refreshed. There's no consistency to this because it'll sometimes let me sign in the first time or it'll take 3 times of trying to finally sign-in. Once I'm in on the dashboard I'll try to navigate to an option and kick me right back to the sign in page again which the whole cycle starts again. I'm using IPower as my host and installation went through without an errors. There are no errors when signing in and it'll just keep kicking me back to the sign in page. After multiple sign-in I'm able to navigate the dashboard and edit the site but it'll eventually have me sign in again.

View Replies:
jbx replied on at Permalink Reply
jbx
Well, this is some kind of session issue, which means there is either a problem with the way your host is storing the sessions, or there is a problem with the way your browser is storing cookies. Theoretically, it could be an issue with your install, but I would look at these 2 options first.

The cookie option is the easiest to check - try a different browser and see if that fixes it. Post back with your results and we'll go from there...

Jon
sorrells replied on at Permalink Reply
We can rule out a browser issue because this happens at various locations with any computer I use.
Mnkras replied on at Permalink Reply
Mnkras
try re-uploading the /concrete folder
sorrells replied on at Permalink Reply
ok I just uploaded the Concrete folder again with the same results. still not fixed.
jbx replied on at Permalink Reply
jbx
Can you check what your session expire time is on your server? Should see it in a phpinfo file, or checking in your php.ini. If that looks right, try monitoring your session folder while logging in and browsing - see what's going on in there...
sorrells replied on at Permalink Reply
php.ini is blank except for the line that says registers_global=off
sorrells replied on at Permalink Reply
does anyone have any other ideas? I'd like to get this solved so the site can go live.
smross replied on at Permalink Reply
So I believe I was having a similar issue on iPower. I would try to sign-in, but couldn't get in (didn't try more than 2-3 times per session). My Debug level was set to Development, and I would see two errors towards the bottom of my page (which I unfortunately didn't record). I got in touch with iPower Support, and they set the 'session.save_path' in the 'php.ini' file to fix the issue.
Unlike other hosts, iPower seems to lock folks a level or two higher in the directory than other hosting services I've used, and C5 was trying to reach a file that it/you can't access.
Hope this helps!
jbx replied on at Permalink Reply
jbx
Yep, this was the exact issue I fixed for Sorrells. I did submit an update to C5 that I was hoping would make it into 5.4.1, but was possibly too late. It enabled you to easily move the session handling into the database. That wpould fix the issue you were seeing and also it's invaluable for large scale deployments on loadbalanaced webservers where you need sessions to persist even if a server goes offline and the users get bounced to another server.

Hopefully be in the next update!

Jon
sorrells replied on at Permalink Reply
Yeah that would be the fix. JBX got me all squared away with the revision he made. That would be great to see that as a feature in the next release.
jans replied on at Permalink Reply
jans
We're hosting via Amazon EC2 and apparently have the same issue. I'd really appreciate it if you could send me this fix also.

Thanks!
sorrells replied on at Permalink Reply
create a /session directory on your host and give it full read-write permissions and then in your php.ini add a line like this

session.save_path = /"enter your host's directory path"/session
zoinks replied on at Permalink Reply
This is happening to me on Safari and Chrome, but not Firefox. And it only is affecting one user group, not the Administrator group. Very odd.

I checked the way Safari stores cookies and it is set to "Never block" them. I checked the cookies and nothing was listed from my website. Do I need to turn some sort of cookie server setting on in my dashboard so that Safari will actually receive a cookie?
zoinks replied on at Permalink Reply
I am having this issue with only non-Admin user/groups on 5.4.2.1.

I added a group called "Editor" and gave it read and edit permissions for certain pages. After I click around a couple times on pages it DOES hav permissions for, it logs out. I can log in and get right onto that page it just logged me out of.

So, it is a sessions issue. How do I fix this if it is only affecting non-Admin user/groups?
globalnerds replied on at Permalink Reply
globalnerds
There is an issue with this and as far as I know it is a known bug.

Add your user administrator group and leave those group settings alone. This user will not have the full admin rights as the userid that created the site.

If you are able to login with that userid, then you can try to take away any permissions that you don't want that group to have. This will NOT effect the userid that was used to install concrete5.

I know this all sounds a bit odd (you would think you could create a new group!), but this has worked for me.
zoinks replied on at Permalink Reply
that does sound weird. How can I take away permissions from a user that has been added to the Administrator group? Permissions are granted by checking the group on each page, not the user. What you're saying to me makes no sense to me.