Disable and Clear the cache

Permalink
I cannot find anything anywhere telling me how to do this. Can anyone help please

View Replies: View Best Answer
12345j replied on at Permalink Best Answer Reply
12345j
yoursite.com/index.php/dashboard/settings
brianhayes replied on at Permalink Reply
Thanks

-----Original Message-----
From: Concrete5 Community [mailto:[email protected]]
Sent: 21 April 2011 13:27
To: [email protected]
Subject: Disable and Clear the cache: Disable and Clear the cache
jedininja replied on at Permalink Reply
jedininja
My sites System & Settings page is "Not Found". Even if I use the url you provided. Is there any other way to get to the cache settings or change it in the coding??
weyboat replied on at Permalink Reply
weyboat
jedininja replied on at Permalink Reply
jedininja
Thanks.
I have. Still the same thing.

I'm trying to duplicate/clone this site so I can run some tests and update the versions, but I've had no luck. This site is slowly going down hill and I'm trying to save it.
jedininja replied on at Permalink Reply
jedininja
I was able to find a cahce folder and deleted all docs in that, but it seems to have not fixed the sites cache problem.
shouter replied on at Permalink Reply
shouter
Same problem, i claered the cache but i can't edit my home site. I can edit the whole pages of my site, but not the home page.
jedininja replied on at Permalink Reply
jedininja
I think part of my issue was actually the SOA record. It was using an old server IP after I moved the site. For some reason my client was the only one who was seeing the old site and making changes to it (on the old server) somehow? Still haven't figured out exactly what's going on.
slarcher replied on at Permalink Reply
You should get an IP detection add on for you browser. There ar emany out there like "Show IP" or so which will display the IP address of the site you are currently on.

An other way to make sure that you are on the desired version of your site is to amend your local hosts file and add some rules like xx.xx.xx.xxhttp://www.mydomain.com.au to make sure you are browsing the site you are intend to.

And always remember to restart your browser after modifications.

cheers,
Fastie replied on at Permalink Reply
Fastie
Is it possible to disable the cache by modifying the database directly? If so, which table and record?

My client's site is currently inaccessible, tripping 500 errors for every page. /login works but the dashboard won't come up.

Yesterday, quite by accident, I was able to get to the dashboard. Disabling cache restored the site to operation. Today I cleared the cache, then re-enabled. The site went dark again and I haven't been able to get back in.

It's running 5.4.1.
mhawke replied on at Permalink Reply
mhawke
Have a look in the config table. All the different cache settings are stored in there.

You can also manually delete the files inside the [root]/files/cache folder.

This sounds like your host might have updated your site to PHP version 5.4 which spits out lots of error messages. If you can get to your Dashboard->Environment, you should be able to check what PHP version you are on or check in your host's Control Panel.
Fastie replied on at Permalink Reply
Fastie
I did find the setting in the Config table when I looked there with phpMyAdmin. Strangely, when I exported the database the day before, the settings for cache were not included in the data dump. I had searched it first and not seen the setting, which led me to believe I was looking in the wrong place and prompted my post here.

Anyway, flipping the switch solved the problem.

PHP is at 5.3.27. The build looks new, in September, so maybe that was the problem. I was not involved until last week, so I don't really know the history.

I remain a bit confused by caching. The cache was full of stuff, but 48 hours ago I cleared it using the Dashboard. A lot of files and folders remained with dates earlier than the date I cleared it. So I've taken your advice and cleared it manually. I'll see what happens when I turn it back on.

I appreciate the good tips. Thank you.
Fastie replied on at Permalink Reply
Fastie
I turned it back on and the site went dark. Looks like I'll have to leave it off.
aptus replied on at Permalink Reply
I found that I could disable the cache by simply revoking write permissions on the files/cache folder.