Edit Bar Missing On Site

Permalink 5 users found helpful
I am working on a new site and cannot access the edit bar on each individual page. I can still access the dashboard, but can't edit the pages.

I thought orginially it was a theme issue. After I switched the theme back to the default, the edit bar still did NOT show up. I feel like it is something out of the actual theme folder. Can anyone help me out?

Thanks a lot,
Brent

bcomsolutions
View Replies: View Best Answer
Tallfrog replied on at Permalink Reply
Tallfrog
Hi,
Did you upload a customized theme? If so, you might of forgotten to add the header snippet of concrete5.

You should have this in your header.php, inside the elements folder:
(After your stylesheets)

<?php  Loader::element('header_required'); ?>


If not, it might be a permission issue.
glockops replied on at Permalink Best Answer Reply
glockops
Actually it's more likely that you are missing the following code
<?php  Loader::element('footer_required'); ?>

This should go immediately before the closing </body> tag. Put it in your theme files or theme footer.

Concrete 5.5 moved a lot of Javascript to the footer - this will allow it to load.
milhealth replied on at Permalink Reply
milhealth
Perplexed? Gentleman, I tried the solution you kindly shared (re: code snippets), what is very weird... I get the edit button/dashboard drop-down 'menu' on all pages EXCEPT, for 4 sub-pages (which are all right side-bar, all in the same place).

All the other subpages function perfectly (even the right side-bar pages!).

I did the following:

1. applied the codes as you both indicated.
--> When I added the code, previously functioning pages did NOT function anymore (edit function disappeared).
--> When I removed the code, the 'working' pages DID work again (editing functions). Those 4 pages remained the same (cannot edit).
2. made sure all permissions 'jived'.
3. made sure all the attributes would work (and even unchecked any).
4. changed the design type to left side-bar, full, etc. Nothing changed, still cannot edit.
5. cleared the cache in C5 as well as in my browser (Chrome).

I saw in another forum post about javascript -- (my right/left side-bar.php pages appear under here.)

One more thing I'm going to try is create a new (test) page in the same place these 4 pages exist, and see if I am able to edit it or not. // 12:54: I did add a new page...and I was able to edit it. ?? (thanks again!) I also ran chron job/(s).

Anything you can suggest would be greatly appreciated. THANK-YOU!! :-)
Karen
______
1:20p Now, more sub-pages are doing the same AND, I'll get the Edit button/drop-down (dashboard), the blocks will 'appear', but edit disappears! Even if I click in the boxes, nothing happens. ?? This is getting stranger and I'm not getting any where ... thanks!
adamjohnson replied on at Permalink Reply
adamjohnson
Could be an add on you have on those specific pages interfering with some of C5.5's JS too.
milhealth replied on at Permalink Reply
milhealth
Hi Riotaj, thanks for your reply! ( I had added on to this post, but hadn't hit reply/enter...so I'm just reading your reply now).

That's a good idea! At some point in the very beginning, it had crossed my mind BUT it didn't 'stay' there. That happens w/WordPress too.

Thanks so much for replying!! I'll try that and let you know. I have a feeling it will work :-)
Karen
milhealth replied on at Permalink Reply
milhealth
Cleaned up the add-ons (removed those I'm really not 'using', etc.), no luck. Still cannot edit some of the pages. Not sure what to do at this point, except 'redo' them. One of the pages, the 'edit' button appears, but then disappears after I click on it. The screen shows the editable sections/blocks but if you click on them nothing happens (you can't edit, add a block/delete, etc). I'm going to try one more thing, change the theme and see what happens. Have nothing to lose :-) ke
chrisjterrell replied on at Permalink Reply
chrisjterrell
I am having a similar problem after I set some of the defaults for my left_bar page type. Now when ever I save an edit on the sheet the edit bar is visible but blank. Would love any help because it quite frustrating not being able to edit a page!

Any help would be appreciated.
Erik74 replied on at Permalink Reply
Check how your theme is built.

I made the error to add "footer_required" to the end of the template. Then the edit bar got screwed up.
When I looked at the code I see that I had a header and footer and top inclusion and the footer_required was already there. When I cleaned out my footer_required everything worked again!
chrisjterrell replied on at Permalink Reply
chrisjterrell
I checked and Header_required is only used once at the top of the header right above </head> in the header.php and the footer_required is right above the </body> in the footer.php and both are only used once.

I think it has to do with setting the defaults I set for the the page types but not totally sure. Everything is working fine except for those pages
ZDV replied on at Permalink Reply
ZDV
Did you ever fix it? I just copied my site to another host, and am now having the missing Edit bar on the home page of the new site, but it works fine on the old.
Abs0lute replied on at Permalink Reply
Abs0lute
I am having this issue too. Funny thing is the Toolbar shows in IE9, just not Safari or FF.
Suggestions?
Concrete5SpammingCunts replied on at Permalink Reply
Just a quick note to say that I had this problem and it was down to my stylesheet having a general style that affected the edit bar. Just comment out your stylesheet in the template and see if that helps.
edpastelak replied on at Permalink Reply
Thank you glockops. That did the trick for me.
jaline replied on at Permalink Reply
jaline
Adding the footer required PHP worked for me.
moran replied on at Permalink Reply
moran
I LOVE YOU!!!!!!!!!!!! I've been unable to edit my site for over a week. I'd buy you lunch if I could!

Larry
petenorris replied on at Permalink Reply
Genius! thanks. I put all my scripts references in-between the footer required and the closing body tag
black0r replied on at Permalink Reply
Have the same problem with my site but header required and footer required are in the page :(
wdclarke replied on at Permalink Reply
Hi, I am a complete newb, and have a brandnew site i just started building with C5. I know nothing about scripting etc, but I managed to find the header and footer php files, and what is described here as needed are already there (they should be, shouldn't they, if I having been monkeying about with the code?) --yet I suddenly get a grey bar instead of an editing one too
b1zki7 replied on at Permalink Reply
b1zki7
how weird is that! the footer required command is exactly what i needed, nice one, thank you!
wdclarke replied on at Permalink Reply
Hi, I am a complete newb, and have a brandnew site i just started building with C5. I know nothing about scripting etc, but I managed to find the header and footer php files, and what is described here as needed are already there (they should be, shouldn't they, if I having been monkeying about with the code?) --yet I suddenly get a grey bar instead of an editing one too
wdclarke replied on at Permalink Reply
SAorry about the multiposts -- the post reply box froze, so I tried again and again, gave up and refreshed the page and there they all were, of course
Blenderite replied on at Permalink Reply
Blenderite
That happens sometimes. To tell if it has 'taken' is to look up at the the tab at the top of your browser. If there is a circle thingy turning, that means that it is still working. If not, it has posted. If it has stopped, simply x out of the reply box and reload the page.

-Blenderite
Adreco replied on at Permalink Reply
Adreco
Hi wdclarke,

If it was working previously and now has stopped, it is likely something you put on your page is conflicting with C5. If a new add-on was used, try to delete...
It may be possible to roll back to an earlier page version that wasn't broken by accessing it from the dashboard (select the page from the sitemap tree > select Versions > approve a previous version and delete the last/offending one. (I have a tutorial on using versioning here http://blog.arvixe.com/versions-and-concrete5-pages/... )
Also, I've witnessed this behavior on occasion where a gallery add-on was trying to process a picture too large for it to handle. Replacing the overly large image in the File Manager resolved that issue.



Adrian

Arvixe Web Hosting / Concrete5 Community Liaison |
http://www.arvixe.com/concrete5_hosting.............
wdclarke replied on at Permalink Reply
Thanks for your help. No, I haven't done anything, except three things (this is a completely new site)
1. Changed the theme to dark default
2. Added a picture which links to an external site
3. Added links to my wordpress and tumbr blogs on the right
This was 4 days ago. The next time I logged in I got a grey bar at the top.
Trying what you mentioned (revert to previous version) doesn't work as when I click on the home page icon in the site map, I do not get the options as seen in your video -- nothing happens at all.
This is in either Chrome 29, Firefox13 or IE10 BTW

Cheers, You can see it if you like:http://www.wdclarke.org
Adreco replied on at Permalink Reply
Adreco
Hi wdclarke,

Its a real puzzle.
If you'd like, I'd be happy to take a look at your site and help out. PM me by clicking on my avatar.

Adrian

Arvixe Web Hosting / Concrete5 Community Liaison |
http://www.arvixe.com/concrete5_hosting.............
Ogma replied on at Permalink Reply
Ogma
Hi wdclarke
Any joy as I have similar problem on clean install.
No admin bar but dB shows me logging in.

http://www.concrete5.org/community/forums/installation/no-admin-bar...

Thx
Carl
ChrisConcrete replied on at Permalink Reply
ChrisConcrete
A large picture had been the exact problem causing my edit toolbar to disappear had. Thank You, Thank You!!
darkslider replied on at Permalink Reply
I haven't had to touch C5 for a couple of years but I had noticed recently some problems with some old sites I had set up. After upgrading to the the latest version, I was experiencing the missing toolbar problem when logging in as admin.

Although my default.php has the 'header required' statement, there was no 'footer required'. Having added the latter all is well now and I can get on trying to sort some other issues.

So thanks to all.