Email Configuration Issue.

We are trying to setup the email section in v5.7.5.1 and get the following error:
The following error was found while trying to send the test email:
stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Using Google, settings as follows:
user acct OK,
Port: 587 (tls) - also tried ssl.

When trying port 465, C5 just hangs.

Centos 6.6 server as well as Ubuntu 14.

We cannot use our internal servers as they require authentication. We really don't have a problem using php mail. We have an internal protocol to use either gmail or internal servers.

Is there a plugin similar to WP Mail SMTP or Postman SMTP (wordpress) that allows us to configure SMTP authentication etc.?

We couldn't find one -- but that simply means that we may be searching for the wrong critter.


View Replies:
hutman replied on at Permalink Reply
I believe if you login to the Dashboard and go System & Settings -> Email - SMTP Method you should find all the settings you need to setup your SMTP Authentication.
jero replied on at Permalink Reply
As hutman says, the mail config can be found at index.php/dashboard/system/mail/method

The error you're getting indicates that the SSL certificate couldn't be verified. There are a couple of reasons for this. 1) The hostname you're using doesn't match the one the certificate is valid for 2) Your SSL installation doesn't have the right intermediate certificates - this is an operating system thing rather than a concrete5 thing. You'll probably need to update your SSL setup to correct that. I'm using Ubuntu 14.04 too and have no problems.
Incidentally, doesn't seem to exist - maybe that's the issue?