Error Message Help

Permalink
Hi, I am getting the following error message when I install C5 v 5.7.5.3 on my system:

An unexpected error occurred.
Can't inherit abstract function Concrete\Core\Validator\ValidatorInterface::isValid() (previously declared abstract in Concrete\Core\Validator\ValidatorManagerInterface)

Does anyone know what this means or what might be causing it? I've installed this version of C5 for other sites without any problems.

Any suggestions would be appreciated!

1 Attachment

View Replies:
katz515 replied on at Permalink Reply
katz515
From concrete5 Japan user
http://concrete5-japan.org/community/forums/install/post-12147/...

In concrete/src/Validator/ValidatorInterface.php,
comment out the following on line 31

public function isValid($mixed, \ArrayAccess $error = null);


This is a quick work-a-round.
katz515 replied on at Permalink Reply
katz515
Made a bug report.
http://www.concrete5.org/developers/bugs/5-7-5-3/isvalid-doesnt-wor...

Are you using the server which PHP version is 5.3.3?