Fatal error: Call to a member function MetaTables()

So today I ran into kind of a goofy error while trying to install When i went to run the installer it came back with:
Fatal error: Call to a member function MetaTables() on a non-object in C:\inetpub\wwwroot\concrete\startup\exceptions.php on line 7

I knew that the copy of c5 I had was good, since I had used it not minutes before on a local copy and everything worked fine. So I dug a little deeper. Come to find out, that after unzipping the directory into my web root on windows server 2012 r2, (running IIS), the permissions were completely fubar.

I went ahead and set my IIS user back to read and execute for my wwwroot directory, and told everything to inherit. Then I went through and gave write/modify access to the files,config, and packages directories and voila, everything worked fine again.

Just thought I'd throw this out there in case others were running into the problem, a quick google search for the error didn't give anything revealing so I hope this will save some other people some time.

View Replies: