Fatal error: Call to undefined method Controller::getRequestedSearchResults

I have 1 dev and 1 staging instance of my Concrete5 site right now. The files are identical (fresh tar/zip made of dev, taken to staging directly, changed only the site.php file + database export/import).

The dev site (which is Windows WAMPStack) runs perfectly.

The staging site (which is LAMP hosted by 1and1) throws the above error whenever I try to add an image to content block.

-- Fatal error: Call to undefined method Controller::getRequestedSearchResults

and says the method is called by:

.../htdocs/glen/www/beauty/concrete/tools/files/search_dialog.php on line 14

The staging site also has some odd behavior in the admin area -- some screens show only header/sidebar. For instance, the file manager can't be accessed at all.

I know it's not a great idea to dev on Windows and export to Linux, but could that really cause this problem? What could?

Again, this behavior starts on the staging site immediately after a fresh install from dev. The pages load fine, the only problem seems to be doing editing / dashboard managing.

Ideas? Similar issues?

View Replies:
Mnkras replied on at Permalink Reply
make sure all files were upload, that is usually the issue for this type of problem
gregaltmann replied on at Permalink Reply
Thanks for the reply.

But since I did a fresh tar/zip of the site, I'm (reasonably) sure that all of the files moved over correctly.

And it works on the dev server, but not staging.

Just in case, which file normally contains the class/method definitions for Controller?
gregaltmann replied on at Permalink Reply
Rather I should ask, which file(s) should be there that aren't? The definition for the base class Controller is definitely there -- a) I see it and b) I think the site wouldn't work at all if it weren't. I guess it's possible that some derived class isn't there, but I don't know which one.
kirkdavidson replied on at Permalink Reply
I know this post is extremely old. But I'm having the same problem and have found no solution. Using WAMP to develop, and then wanting to post online to a Linux server for the client. I have deleted, reuploaded, purged databases, and still to no avail have I solved the problem. A google search lead me here but there was no definite reply as to how to solve the issue.

Everything on the site works, every feature, except for the file manager. I cannot upload files... editing the pages, creating pages, deleting, and anything else I want to do works perfectly.

Running concrete5.5.1 on dreamhost. Does anyone have solutions?
I read something online about maybe having to chmod /files to 777... tried that but it didn't work.
gregaltmann replied on at Permalink Reply
Hi Kirk - I also never found a solution to the problem. I ended up re-building the site from scratch on Linux, with no more Windows involved at all (except to copy/paste text content).