File Manager Permissions Error

Permalink
We have a Concrete5 site that we built last year. It has been running fine up till 3 months ago when our entire database and all of the files got accidentally deleted from our webhost. We were able to restore everything from backups that were made three (3) days before. I then ironed out the initial issues that were created from the restore by updating to 5.6.1.1. A month later while working on our site I realized that the File Manager was no longer accepting uploads. It currently returns the error:
Unable to copy file to storage directory. Please check permissions on your upload directory and ensure they can be written to by your web server.

I have tried recursively setting all permissions on the files directory to 775 and 777, neither of which worked. Php safe mode is off. I'm running out of ideas. I need to get this back up as we have things to update on our site. Does anyone have any experience with this? Any suggestions would be appreciated.

Thanks,
Caleb A.

sagetech
View Replies: View Best Answer
weyboat replied on at Permalink Best Answer Reply
weyboat
Go to dashboard/system & settings/ Under the "Environment" section, click on "File Storage Locations" and check the path to your files folder is correct.
sagetech replied on at Permalink Reply
sagetech
What should it be? I currently have it set to "/files", without the quotes. My files directory is in the root public_html folder. Another note is that to solve other issues after restoring the site I ran an update. Thanks!
weyboat replied on at Permalink Reply
weyboat
You need to add the full server path to your files folder,
To find the server path do this:
create a file called phpinfo.php and add this code
<?php
// Show all information, defaults to INFO_ALL
phpinfo();
?>

put this file in your root (same place as your index.php file)
Go to your website and add /phpinfo.php at the end of your url, example (www.yoursite.com/phpinfo.php)
scroll down the page until you find the section called "Environment" and look for the row named DOCUMENT_ROOT,
This is your server path just add /files to the end and you have your full path to your files folder..
badams48 replied on at Permalink Reply
badams48
I transferred my website to a new host and found several images not appearing. This was the solution for me. My filepath changed just a bit and with a quick revision, I was in business. Had to go to cPanel to verify the naming. Thank you.
weyboat replied on at Permalink Reply
weyboat
Glad I could help..
Rgds
David