File upload hangs/stalls on files >100KB

Permalink
I've seen this discussed in years past but none of the solutions I managed to find have fixed my issue. I've got a fresh install of 5.6.1.2 and I'm running into the issue where I can't upload files (images) larger than around 100KB in size. I can upload small images all day long.

I've checked php.ini and I've set it from the stock 2MB/8MB to 20MB/20MB just to see if that would resolve it.

I've checked file permissions for the file folder/sub-folders which was set to 755 but I changed them all to 777 while testing to no avail.

I'm hosting the site on my own machine locally running Ubuntu 12.04 and ISPConfig. I've been unable to find any limits within ISPConfig other than the limits imposed by php.ini.

Does anyone know of a solution for this?

vGibson
View Replies: View Best Answer
creativeorange replied on at Permalink Reply
creativeorange
I'm having the same issue with 5.5 and 5.6.
What's weirder than it will upload some JPGs and none of others. I haven't changed how I save files (Photoshop Save as Web). It's like a permissions issue that I can't tag down.
vGibson replied on at Permalink Reply
vGibson
Still been unable to locate the issue but it's consistent. Any image/file over approx 100K in size just hangs the upload process.
vGibson replied on at Permalink Reply
vGibson
I'm still having this issue if anyone has resolved it please advise. It's quite annoying. Thanks
Blenderite replied on at Permalink Reply
Blenderite
MoonGrab replied on at Permalink Best Answer Reply
MoonGrab
If you run PHP in FCGI mode (which you probably do with ISPConfig), then I have your solution. I have the exact same setup in the office and it took me like 10 minutes to resolve it (which is a lot for me =)).
Open up /etc/apache2/apache2.conf

Scroll to the bottom
Put this on a new line:
FcgidMaxRequestLen 20000000

Restart your Apache & PHP and you're good to go.

BTW, not a c5 issue, you're gonna have this issue everywhere without this setting.
2hz replied on at Permalink Reply
2hz
Thank you for this, really helpful :) Helped my a lot.