Function mysql_connect() not found

Okay, I'm going to preface this by saying that I am a simple Designer, so speak slowly and use non technical terms :)

Anyways, I set up an Apache server locally (Windows), and managed to install PHP5 correctly. I believe I installed MySQL correctly (enabled the extensions in the php.ini file, set up a user/database) but I'm not entirely certain about this.

When I run the Concrete5 test, I get this message : Function mysql_connect() not found. Your system does not appear to have MySQL available within PHP.

Any idea what the problem might be, or where I should look? I've followed all of the suggestions online that I've found, but so far nothing seems to work.

If it makes a difference, I installed PHP manually.


View Replies:
chunksmurray replied on at Permalink Reply
These things can be annoying!

Double check your php.ini file and make sure the extension=php_mysql.dll is definitely uncommented.

Also check the following line is uncommented (change to suit your installation path for PHP):

extension_dir = "C:\php\ext\"

If that doesn't work, it may also be helpful to use phpinfo to check your settings. You can download the Concrete5 provided one from here: and just upload it to your host and then browse to it. (i.e
rfertner replied on at Permalink Reply
Doubled checked and extension=php_mysql.dll is definitely uncommented, as well as extension_dir = "C:\php\ext\"

The phpinfo doesn't bring up anything at all about mysql. Does that mean that perhaps the problem is with Apache recognizing MySQL? Or something else entirely?
Mnkras replied on at Permalink Reply
if you are having a lot of trouble i suggest you use wamp,

its a lot easier to run and install as it runs out of the box, i use it on my pc
rfertner replied on at Permalink Reply
Ooo... Thanks for the suggestion, I think I'll try that instead.
chunksmurray replied on at Permalink Reply
Yeah WAMP would be easier for sure. But if you are still keen on doing it manually, the best thing to do would be to start fresh with new copies of both php.ini and httpd.conf files. Then go through the setup again. I find that these problems usually come from a random line that was missed etc.