get theme path not working, after install in sub directory

I've installed C5 in a folder called 'new' just of the main directory.
I've uploaded my theme but it's clear the theme paths aren't being correctly pulled out as no stylesheet or images are being picked up.

I'm using <?php echo $this->getThemePath(); ?> to reference these.
If I go into firebug I can see that at every point, Concrete is trying to go into the Concrete folder:

Whereas I've only ever uploaded themes straight to the themes directory in the root of the install:

Have things changed and am I now uploading in the wrong place or is there something else that's going on here?


View Replies:
lou28 replied on at Permalink Reply
If anyone can help I'd be very grateful.

enlil replied on at Permalink Reply
The proper place to install a theme would be in root/packages/
The root themes folder is where you should do any overrides to your theme you'd like. Try putting the theme in the proper folder and see if things work properly!
adajad replied on at Permalink Reply
@enlil: actually, if you create a theme yourself and don't create a package it is totally correct to upload the theme to root/themes. The reason you would want to create a package of a theme is if you plan to install it on many sites and there are some deeper logic involved. That way you can push out updates more easily.

@lou28: you shouldn't need to, but you can try to set DIR_REL to '/new' in root/config/site.php
define('DIR_REL, '/new');
lou28 replied on at Permalink Reply
I've just tried that but it didn't seem to make any difference unfortunately.

I also get this error message on the home page:

File /home/sites/ not found. All themes need default.php and view.php files in them. Consult concrete5 documentation on how to create these files.

I have uploaded the theme I created in the same way I have done with the past 20 sites I've created, so I can only imagine that it's the sub folder that's causing the problems...but I can't imagine that I'm the only one who's ever done this??

Is there anything else I can try?

mhawke replied on at Permalink Reply
Anything in your .htaccess file that may be confusing things?

Also, make sure you have your overrides cache turned off in Dashboard->System and Settings->Cache and Speed Settings
lou28 replied on at Permalink Reply
turning off the cache overrides seems to have done the trick - thank you!
adajad replied on at Permalink Reply
Now all you need to do is find the erroneous override.