GoDaddy Windows IIS7 Pretty URL [Solved]

I looked high and low for this and I just wanted to post this in case someone else runs into the problem I did. If you want pretty URLs on a GoDaddy IIS7 Server you should try this web.config:

<?xml version="1.0" encoding="UTF-8"?>
    <identity impersonate="false" /> 
    <rule name="Imported Rule 1" stopProcessing="true">
      <match url="^(.*)$" ignoreCase="false" />
        <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
        <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
      <action type="Rewrite" url="index.php/{R:1}" appendQueryString="true" />

1. Create a web.config with this code
2. Add to you c5 sites root directory
3. Enable pretty urls

It should work. It worked for me. :) Hope this helps someone.

View Replies:
Deladroid replied on at Permalink Reply
I've been searching for this! Thank you! I now have mine working on IIS7.
simonknibbs replied on at Permalink Reply
This is fantastic... It has saved me a lot of time.