Going back to Previous version of concrete?

Permalink 2 users found helpful
Hi,
I just tried updating concrete from 5.3.2 to 5.4.2.2 and it gives me this error once i click "Upgrade"

An Unexpected Error occurred while upgrading: No block found with the handle autonav.

But the site works, but not the dashboard.

In the ftp if i go back to the old concrete folder, nothing works...

How do i make the old concrete version work again? Im completely lost.

Any help would be appreciated. Thanks

Jason

View Replies:
mdzoidberg replied on at Permalink Reply
mdzoidberg
ok, let's try this, to go to the previous version check on your site.php file under the config folder for a line that reads something like the line below and remove it

<?php define('DIRNAME_APP_UPDATED', 'concrete5.4.2');?>


Removing that line will point to the old concrete folder instead of the one under the updates folder.
vpi replied on at Permalink Reply
Hey i tried this but i don't have that line in the site.php file.. =/
I downloaded the whole public_htlm folder prior to the upgrade. Maybe i should just reupload that and cruch all existing files?
chrison999 replied on at Permalink Reply
I had a problem upgrading from 5.4.2.2 to 5.5.1 and was not able to access my site (got a "Database Error" message). Removing that line from my site.php file did indeed get me back to the previous version.

THANK YOU so much for that tip! It likely saved me hours of work!

Regards,

Chris
danielboccato replied on at Permalink Reply
THANK YOU!!!!!!!!