Google SMTP External Mail not working on new web host

Permalink
Hi,

I have moved a site to a production web server (Apache) with the clients previous hosting company.

Sending form submission notification emails using 'External SMTP' with Google Mail is failing. It is returning a blank screen with the url:

http://{domain}/index.php?cID=199&bID=1486&arHandle=Main+Co...

I had it working on our demo server using the client account details, and the following settings:

Email Server: smtp.gmail.com
Security: TLS
Port: Default (25)

Other settings:
The 'FORM_BLOCK_SENDER_EMAIL' setting is set in /config/site.php.

I have checked with the hosting company that the ports aren't blocked (25, 465, 587) and have tried a combination of settings on the new web server (TLS, SSL).

We are using Concrete 5 5.5.2.1, and PHP 5.3.6.

I have Concrete 5 logging and debugging, and PHP display_errors turned on, yet we are getting no error messages on screen or, in the logs.

I added logging using Concrete5's
Log::addEntry()
, which logs up until the point the Mail helper is called in Form block controller. The log statement after the
@$mh->sendMail();
call is never hit.

I have tried adding Zend logging statements for the Zend SMTP library but I haven't been able to get either PHP outputted errors, or log file errors working.

Has anyone had the same issues with sending mail with an external SMTP server? Or has any suggestions or solutions?

View Replies:
mnakalay replied on at Permalink Reply
mnakalay
Did you check with your host if they actually allow the use of external smtp servers? Some of them don't allow it and block them.

Meanwhile, a quick fix would be to have the messages sent to the email provided by the host (they always offer free emails) and configure your gmail account to automatically grab the emails from their servers.

Good luck
Brainakazariua replied on at Permalink Reply
Brainakazariua
The correct settings for using the gmail smtp are:

SMTP server address: smtp.gmail.com
SMTP user name: Your full Gmail address (e.g. [email protected])
SMTP password: Your Gmail password
SMTP port: 465
SMTP TLS/SSL required: yes

You need to use those to be allowed to use their outgoing smtp.
jamesdev1 replied on at Permalink Reply
I am aware of the correct settings for using Google Mail SMTP. We have tried all combinations of the three ports (25, 465, 587) and none have worked. On our demo site, 25 was the port that worked.
turbodynamics replied on at Permalink Reply
turbodynamics
in my case this credentials doesn't work, my server is allowed to send mail cause i tried to run a script with the PHP function mail(), but i set up the google credentials and it is not sending email, i could see in the logs "from:" is empty and the error that i could get is:

Mail Exception Occurred. Unable to send mail: <>: missing or malformed local part

any advice please?