Having issues installing on Windows server, Unable to open config/site.php for writing.

Hello everyone, I am having the hardest time installing C5 on a clients webserver. When I open the installation page, I open all my information in and the the system comes back with the error message, "Unable to open config/site.php for writing." What does this mean? I have never had this issue on Linux based servers. I have checked and confirmed that the permissions on the config folder was 777.I really have no idea what to do in this case. There is no site.php file in the config folder, no tables in the database. The server is running IIS 7.0, along with PHP 5.2 and all of the required server features are check on the initial installation page. Please help me out on this, my deadline is quickly approaching.

View Replies:
citytech2 replied on at Permalink Reply
What do you mean by the below line?
"There is no site.php file in the config folder"
There must be a site.php file in your roots config folder.

Another confusing point is the permission. You have told that you want to install it in windows platform. How could you set 777 in a folder of windows platform?

jero replied on at Permalink Reply
config/site.php gets written by the installation process, and at the start the file doesn't exist.

The problem you have is that your config folder is not writeable by your webserver, despite what the initial tests might suggest. Either that, or your server is trying to write the file somewhere else.
cecil4 replied on at Permalink Reply
I know that the folder is not writable, what I find strange is that it has 777 permissions. There should not be a problem. But I decided to switch the server to Linux. Windows sucks!
slicksid replied on at Permalink Reply
I am having the same problem - for testing purposes I have given the everyone user write permissions on config/ and files/ and it is still coming up with the error.

I am running C5 in a subdirectory of wwwroot so where might it be trying to write the file?

Also, the images aren't showing, even though the url is correct when I view the source.
kevin001 replied on at Permalink Reply
I realize this is an old post. I just stumbled across it and wanted to give some input.

A Windows server usually doesn't have PHP installed by default. If you're running locally, it's easy to install PHP. With most hosting companies now, PHP and open source software should be an option.I've run across this myself with old clients.