How to disable pretty URLs

Permalink 1 user found helpful
After enabling pretty urls I get a 500 Internal Server Error. I cannot even login or access the Dashboard. I would like to undo this change and get my site running again. Can I disable pretty urls via phpMyAdmin? If so, please instruct me on how to do this. Thanks

View Replies:
LucasAnderson replied on at Permalink Reply
LucasAnderson
Did you update the .htaccess file as instructed after enabling Pretty URLs?
skymark replied on at Permalink Reply
Yeah I did. I've spent the last few hours trying to get it to work, but now I just want to roll back so that I have a working site. Do you know how to disable pretty urls through the database?
LucasAnderson replied on at Permalink Reply
LucasAnderson
Yes. It'll be in your Config table within the database. Set the value of URL_REWRITING to '0' (zero) instead of '1'.

You'll also want to remove any edits you did to .htaccess
skymark replied on at Permalink Reply
Thanks, that should do the trick for the time being
jbx replied on at Permalink Reply
jbx
After you've done that, post up what you had in your .htaccess and also some server info (a phpinfo() page would be great) and we'll hopefully be able to tell you how to fix it...

Jon
greenfleck replied on at Permalink Reply
I have had the same problem and am not sure how to solve this. I have set the URL_REWRITING value to 0 and attempted to remove edits to the .htaccess but I am still having the same error and cannot access the Dashboard.

My .htaccess looks like this:

# -- concrete5 urls start -- RewriteEngine On RewriteBase /students/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ index.php/$1 [L] # -- concrete5 urls end --
TheRealSean replied on at Permalink Reply
TheRealSean
Wrap your Rewrite in this
<IfModule mod_rewrite.c>

</IfModule>
That way it should not break if you dont have access to mod_rewrite

Are you running on a shared server?
msglueck replied on at Permalink Reply
msglueck
you need FollowSymlinks enabled for mod_rewrite to work.
usually the 500 Error is originating from this.

add Options +FollowSymlinks to your .htaccess.

If you still get the 500 error check if you have AllowOverride All or AllowOverride FollowSymlinks in httpd.conf enabled otherwise the Symlink-option in .htaccess is not allowed and Apache is picky about that, thus throwing a 500.
babukk replied on at Permalink Reply
I had similar problem after enabling pretty url. I updated the .httaccess as explained but nothing worked. Even I was not able to disable the pretty url anymore. After struggling, I disabled it by getting into site settings directly by giving the following command..

http://localhost/c5/index.php?cID=53...