I just installed concrete5 on my wamp server on windows 7

Permalink
Thanks to t00thless for his write up!

It took me half an hour to find the info in the forum, mostly because I wanted to read lots of irrelevant stuff. But I noticed people got helped, things got fixed and now I too can say installation was about 5 minutes from start to finish and I just finished browsing through my dashboard in my fresh clean installation. Wordpress is ok but concrete5 makes so much more sense to me right off the mark.

Thanks much!

View Replies:
Torquee replied on at Permalink Reply
I followed the instructions to a tee and ended up receiving an "Unable to connect to database" message. I'm new to this so would you, or anyone, happen to have any suggestions as to what I might be doing wrong? I'm using PHP 5.2.9-2, MySQL 5.5.8, WAMP 2.1 and Concrete 5.4.1.1
jodzeee replied on at Permalink Reply
Help! I also followed the instructions and cannot connect to the database. Now what?
WebcentricLtd replied on at Permalink Reply
Does the WAMP manager icon show in your taskbar and is it all running.

Were you able to install Concrete5 ok? Did you get to the point where it gave you a password?

if you go tohttp://localhost/ do you get the WAMP admin page with the various subdirectories shown etc.

If so, on that page you should have a link to phpmyadmin - does that work if you click on it?

If not, do you have a firewall running?
jodzeee replied on at Permalink Reply
Yes, WAMP is running and working fine;http://localhost shows as it should and I have a site that uses some PHP includes that is working fine.

This is my first attempt at doing anything with a database though (I'm clueless!) ... so I followed these instructions:
http://www.concrete5.org/documentation/installation/hosts/installin...

After I changed the password there and in config.inc.php, phpmyadmin says:

Error

MySQL said: Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: YES)
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

So no, I'm not finished installing Concrete5 because I haven't created the database (according to those instructions) yet :(

Thanks for your help, it's much appreciated!
jodzeee replied on at Permalink Reply
Okay, it was my mistake. I went back into the config file and deleted the password, then it worked. I swear I did that before and it didn't. So then I was able to get back to phpMyAdmin and try again.

Turns out that I hadn't successfully created a password (I pressed the wrong GO button!).

All is working now. Well so far ... I'm sure I'll have more questions!
pmlmedia replied on at Permalink Reply
pmlmedia
I had the same error following these instructions using the latest version of WAMP.
In addition to adding your password between the ''s in config.inc.php you also need to change ['AllowNoPassword'] = true; ...to... = false;