IIS 7.0 PHP 5.2 Permissions Issue (GoDaddy)

I'm am trying to install the latest Concrete5 on my shared hosting Windows server. I can't seem to pass the test for :

Web Server Access to Files and Configuration Directories

I unzipped the concrete5.5.2.1 folder into a sub directory off my root folder and made the whole tree read and write. I am still getting a fail for this test.


There seems to be tons of support for Apache servers in these forms, but not much in the way of IIS support. Can anyone offer some help for this issue?

View Replies:
adajad replied on at Permalink Reply
If you use a devent ftp client (like Filezilla) you can set file permissions in numerics (i.e 755), much like you would on a *nix filesystem.

Download Filezilla and ftp to your host. Right click on the folder in question and select 'File Permission' (or what it might be in English since I'm on a Swedish installation).

Myishmael replied on at Permalink Reply
I tried using CHMOD 755 through FileZilla however it came back with a:

500 'SITE CHMOD 755 files': command not understood

Again I think this has to do with the Windows Environment. I was able to set all of the permissions via GoDaddy's FTP File Manager, but I am still having no luck.
adajad replied on at Permalink Reply
I have no previous experience with Bluehost, but I have set up concrete5 with IIS a couple of years ago, but on a win2003 server. Have you read these instructions (which helped me and might at least give you pointers for IIS7)? http://www.concrete5.org/documentation/installation/hosts/windows_s...

...anyways, my IIS install was for evaluation only and I decided to go for Apache once I had settled for concrete5 mostly because the support in the forums and generally on the internet is better for Apache.

Right now I'm running IIS and Apache side by side on the same server (I know it might not be the best practice) with two concrete5 sites and two simple html sites on Apache and two .ASP sites on IIS.
landollweb replied on at Permalink Reply
I ran into this problem installing C5 on our IIS7 server. Setting permissions in the Windows file system is a little different than in the LAMP environment, and it can be confusing which user IIS7 is actually using to access the files.

In my case, it turned out that I was granting write access to the wrong user. I was trying to grant access to the system accounts that IIS7 uses to access the file system by default.

I have a special dedicated user account set up on the server and set the site to use that account to access its files. I don't know whether you can do this yourself in a shared hosting environment, but I set this through "Basic settings" for each of my web sites, then set the "Connect as..." to use the user account I set up.

Then I went to the file system and granted my user write access.

If this is not possible in your hosting control panel, I would try contacting the hosting support team and confirming which account your site is using to access your web document file system.