Image Upload issues with GoDaddy

Permalink 1 user found helpful
Hi all

Back with another problem from your favorite web host. One of my clients is currently using GoDaddy (at the moment in time, we can't switch).

We are unable to upload images, we get the following error:

An unknown error occurred while uploading the file. Please check that file uploads are enabled, and that your file does not exceed the size of the post_max_size or upload_max_filesize variables.

File Uploads: 1
Max Upload File Size: 32M
Post Max Size: 33M

The file I'm uploading is 60kb, so that obviously isn't the issue.

The site is currently running in a sub directory.
IE: is the root URL.
/mysitecom/ is the site root.

My php5.ini is as follows:
session.save_path = tmp/

file_uploads = On
upload_max_filesize = 100M
post_max_size = 100M
upload_tmp_dir = tmp/

(Looks like my settings aren't having any effect)

Any ideas?

View Replies:
johnpaulb replied on at Permalink Reply
Hello Job,

I would check to make sure there is not a recursive php.ini above the php.ini you are editing.

It may be specifying a different php.ini location in the .htaccess file. I work for Web Hosting Hub, but I think godaddy uses a similar setup.

For reference, here is a link to an article on making your php.ini recursive:

I hope this helps,
nkennel replied on at Permalink Reply
Hey Job,

You helped me by pointing out that the issue may be with php.ini (in my case php5.ini). So first, thank you.

I copied your settings into my php5.ini and I still had the issue. Then I removed all of the related settings from php5.ini, and looked at the output from phpinfo(). All of the upload settings seemed fine accept no upload_tmp_dir was not defined. I simply added a forward slash before the path and this fixed my issue!

By the way, I had to edit the php5.ini file to install Concrete5 on GoDaddy in the first place. Here are the current contents of my php5.ini file.

cgi.fix_pathinfo = 1
upload_tmp_dir = /tmp/
SteadyIT replied on at Permalink Reply

Can you please outline what these lines are referring to in the php5.ini file:

session.save_path = tmp/