Ini_set disabled on webserver makes installation impossible

Permalink
Hi,
is it possible to use concrete5 when ini_set is restricted? I don't even get to the installation page, just getting a blank page and these errors:

Warning: ini_set() has been disabled for security reasons in /home/www/***/www/***/concrete/concrete/config/base.php on line 137
Warning: require_once(Zend/Cache/Backend/File.php) [function.require-once]: failed to open stream: No such file or directory in /home/www/***/www/***/concrete/concrete/libraries/3rdparty/Zend/Cache.php on line 133
Fatal error: require_once() [function.require]: Failed opening required 'Zend/Cache/Backend/File.php' (include_path='.:') in /home/www/***/www/***/concrete/concrete/libraries/3rdparty/Zend/Cache.php on line 133


I already asked webhosting support and they said that it is not possible to allow ini_set, because it is shared hosting, but they can change specific settings when I write them what I want, so if it is possible what are the necessary changes?

View Replies:
Brainakazariua replied on at Permalink Reply
Brainakazariua
It's not the warning about the ini_set that is the problem.
It's the fatal error which you get on Zend. They most likely don't have Zend enabled on the server.

Contact them again to check that or add an info.php to your site with the following code to check if it is enable yourself:

<?
phpinfo();
?>
s4pphir3 replied on at Permalink Reply
Thank you for your reply, it seems that Zend is enabled but it still didn't work.

But I solved it by moving the Zend folder from concrete folder to the folder where default include path points, which is root in this case.

Then I also got an error about the PATH_INFO/ORIGIN_PATH_INFO but that was solved by turning off display_errors in php settings.
jakubt replied on at Permalink Reply
I have the same problem.

Were you able to solve this?

Warning: ini_set() has been disabled for security reasons in /home/www/historickededictvi.com/www/monasterium.historickededictvi.com/concrete/config/base.php on line 135
Warning: require_once(Zend/Cache/Backend/File.php) [function.require-once]: failed to open stream: No such file or directory in /home/www/historickededictvi.com/www/monasterium.historickededictvi.com/concrete/libraries/3rdparty/Zend/Cache.php on line 133
Fatal error: require_once() [function.require]: Failed opening required 'Zend/Cache/Backend/File.php' (include_path='.:') in /home/www/historickededictvi.com/www/monasterium.historickededictvi.com/concrete/libraries/3rdparty/Zend/Cache.php on line 133


Which folder did you move and where? How do I find out where to move it on my hosting?
Giraffe3 replied on at Permalink Reply
Hi, I'm having the exactly same issue. Appreciate if anybody can help to iterate the procedure on details. Don't want to move the wrong folder or write a wrong function. Thanks a lot in advance.
mrjcgoodwin replied on at Permalink Reply
mrjcgoodwin
Hi all,

I just recently had this problem when switching to a new server. These instructions saved the day:

http://forums.glowhost.com/knowledge-base/how-fix-ini_set-has-been-...
3patines replied on at Permalink Reply
I know this is old, but wanted to leave this tip:

This solution works after concrete5 has been installed or can work if the file is modified before installation (haven't tried that) on servers where ini_set() has been disabled.

In the file base.php inside ./concrete/config/ replace the following line:
ini_set('include_path', DIR_LIBRARIES_3RDPARTY . PATH_SEPARATOR . DIR_LIBRARIES_3RDPARTY_CORE . PATH_SEPARATOR . get_include_path());


With this:
set_include_path(get_include_path() . PATH_SEPARATOR . DIR_LIBRARIES_3RDPARTY . PATH_SEPARATOR . DIR_LIBRARIES_3RDPARTY_CORE . PATH_SEPARATOR);
3patines replied on at Permalink Reply
I know this is old, but wanted to leave this tip:

This solution works after concrete5 has been installed or can work if the file is modified before installation (haven't tried that) on servers where ini_set() has been disabled.

In the file base.php inside ./concrete/config/ replace the following line:
ini_set('include_path', DIR_LIBRARIES_3RDPARTY . PATH_SEPARATOR . DIR_LIBRARIES_3RDPARTY_CORE . PATH_SEPARATOR . get_include_path());


With this:
set_include_path(get_include_path() . PATH_SEPARATOR . DIR_LIBRARIES_3RDPARTY . PATH_SEPARATOR . DIR_LIBRARIES_3RDPARTY_CORE . PATH_SEPARATOR);