Instalation - SQLSTATE[28000] [1045] Access denied for user - what to do ?

Permalink 1 user found helpful

Pretty simple problem (I think) I'm trying to install concrete5 on my FTP and MYSQL. I'm new to MYSQL and databases. I run my website from ftp and index.html at the moment.

So I type in my password, server and all. I get the error above + some details.

Can some1 suggest what to do ? My MYSQL /FTP is on



View Replies:
gordonsyme replied on at Permalink Reply
I am having the same problem with mine. if anyone can assist great thank you
sismo replied on at Permalink Reply
I'm having the same problem. My website is housed with Hostgator. I am certain I am inputing the correct details for the host, username, database name and password. Is there a solution to this?
MrKDilkington replied on at Permalink Reply
The error is not exactly the same, but the problem is similar to the issue I had.

The solution was removing certain characters from the password.
juddc replied on at Permalink Reply
Check that the db user has all write priveleges granted to the database.
yoga replied on at Permalink Reply
What do you type into the database server field? What database do you use? Did you point your localhost to the correct database? (some hosting providers have that setting)

depending on this you could try several options:

localhost:3306 (or 3307, 3308, 3309, 3310 depending on your dbase version mysql5.1 has 3309)

Remember you need to run PHP 5.3.3+ to run concrete5. If none of the above help, try setting your PHP to 5.4 and retry. Also, just in case, make sure you can connect to your database with the U/P you're entering when installing C5.

best of luck