Install hangs at database install

I'm attempting to install concrete5 8.2.1 on my DreamHost server, and it continues to hang when it goes to install the database. I enter in all the correct information for the server, and a blank database that I've checked to be empty in phpMyAdmin. It begins creating the database tables, and then every time I run this with a new database, it always errors out and says that "There are already XXX tables in this database. concrete5 must be installed in an empty database.." where XXX could be any different number of tables. I've done this several times from different computers and internet connections and this is always the result. With every attempt I create a new database to install in. I have not tried any other version of Concrete5 on this server. Attached is the exact error message I am getting.

1 Attachment

View Replies:
hutman replied on at Permalink Reply
Have you tried installing via the command line? I've found this method to be more reliable -
leonard787 replied on at Permalink Reply

Thanks for the suggestion, I am unable to make this work either so far, the documentation provided does not explain out the arguments for Concrete5 8+ so I am not sure what to put in some of the arguments, and when I attempt to run the command I get an error "Too many arguments, expected arguments "Command""
hutman replied on at Permalink Reply
This is what I usually use

concrete/bin/concrete5 c5:install --db-server=DB_SERVER --db-username=DB_USERNAME --db-password=DB_PASSWORD --db-database=DB_NAME --site=SITE_NAME --starting-point=STARTING_POINT --admin-email=EMAIL --admin-password=PASSWORD

STARTING_POINT = elemental_full or elemental_blank

I'm not sure if it's necessary or not but if I have a space in my site name I wrap it in quotes.
leonard787 replied on at Permalink Reply
I was able to start the installation process by surrounding my site name spaces with quotes and tweaking a few things, but now I get to the importing files step and the install errors out

65%: Importing files.
Whoops\Exception\ErrorException: Class 'finfo' not found in file /home/newarkfire/ on line 311
Stack trace:
  1. Whoops\Exception\ErrorException->() /home/newarkfire/
   | array(1) {
   |   [0]=>
   |   string(23) "Class 'finfo' not found"
   | }
Gondwana replied on at Permalink Reply
Do you have the php fileinfo extension enabled?
leonard787 replied on at Permalink Reply 1 Attachment
I believe that after PHP5 it is enabled by default

I did check my phpinfo page and it does say that fileinfo is enabled. Attached is the image of that phpinfo section
Gondwana replied on at Permalink Reply
That does look pretty compelling. I'd also be inclined to check in c5's 'Environment Information' for fileinfo, and also CPanel if that's relevant.

Some hosts enable fileinfo by default whereas others don't, so it's worth investigating.
leonard787 replied on at Permalink Reply
Everything looks fine as far as fileinfo goes, do you have any idea of what the issue may be if it is enabled on the server and the installation process is just able to use it? When I was originally attempting to install with the GUI, I was able to start the install because the installer checked for the fileinfo extension to be enabled
leonard787 replied on at Permalink Reply 2 Attachments
I attempted to use DreamHost's one click installer of, as well as installing manually, and I now get a different error. The errors are all variations of the following. The installer will get to Adding Block Types, and then it will display an error message that looks like the following. It is not always the same block type, it has happened with several. I've attached screenshots to this reply.

An exception occurred while executing 'CREATE TABLE btNextPrevious (bID INT UNSIGNED NOT NULL, nextLabel VARCHAR(128) DEFAULT NULL, previousLabel VARCHAR(128) DEFAULT NULL, parentLabel VARCHAR(128) DEFAULT NULL, loopSequence INT DEFAULT 1, excludeSystemPages INT DEFAULT 1, orderBy VARCHAR(20) DEFAULT 'display_asc', PRIMARY KEY(bID)) DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci ENGINE = InnoDB': SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'btNextPrevious' already exists.

I've either started with a new database or dropped all the tables and ensured it was empty when I started. I have no idea at this point what the issue would be, I expected one version of concrete5 to install successful on my server, but I am having no luck with any of them, and I've done manual installs successfully on other servers in the past.
Gondwana replied on at Permalink Reply
I wonder if there's some weird caching going on.