Install keeps erroring with concrete5 must be installed in an empty database..

Permalink
This is the message I keep getting when trying to install concrete5

{"error":true,"message":"There are already 86 tables in this database. concrete5 must be installed in an empty database..

The number of database tables in the error changes every time I run it and when I go to clear out the database there is always 249 tables.

I am hoping there is a way to maybe alter the code to skip the database generation?
I increased the max_execution_time but that didn't do anything to help the problem.

Is there anything I can possibly do to get concrete5 to install?

View Replies:
CMSDeveloper replied on at Permalink Reply
CMSDeveloper
What's your hosting enviroment?
somethingsketchy replied on at Permalink Reply
Apache 2.4.25
PHP: 5.6.30
MySQL: 10.0.28-MariaDB
Perl 5.10.1

php.ini
max_execution_time 180
memory_limit 256M

I am using SynHosting as my host.
Gondwana replied on at Permalink Reply
Gondwana
drop all of the tables (or recreate the database) before each attempt to install. That, combined with the extended max_execution_time, might get you there.
somethingsketchy replied on at Permalink Reply
i cleared the tables and increased the max_execution_time but still fails
Gondwana replied on at Permalink Reply
Gondwana
Make sure you DROP the tables (all of them!), rather than just empting them. Depending on your environment, you may not see all of the tables at once.

If you can't get that to work, delete the database and recreate it.
somethingsketchy replied on at Permalink Reply
I drop all 249 tables. When i go back to the database it shows nothing.

Run the install it will start creating the database and after a few min the installation will fail with the following message.

{"error":true,"message":"There are already 248 tables in this database. concrete5 must be installed in an empty database..

The only option is to hit back and start the installation over.
Which again I go drop all the tables and try and install it and the same thing happens.

I increased the max_execution_time to 1200 and it will still fail.
It seems like tries to install the database again after it already started installing the database.
mlocati replied on at Permalink Reply
mlocati
You could check the PHP error log to see if the installation fails for some reason.
Furthermore I'd try to increase the memory limit.