installation error

Permalink 1 user found helpful

Trying to install the latest version and get this error

Class \Concrete\Job\.CheckAutomatedGroups does not exist.

any ideas?

View Replies:
leal replied on at Permalink Reply
Have a similar problem - I too am installed C5.7.3.1 and on Page 3 get this message (and am stuck)

"Class '\Concrete\StartingPointPackage\Blank\Controller' not found "

Also had a problem on Page 2 with errant file permssion not being recognized until folders were manually put in.

C5.7.3.1 install files were created from a file uploaded to servers and unzip using pUtty shell unzip command.

Concrete5.7.3.1 Install package pages have seen

Page 1 - select language
page 2 - Testing required/Optional/Memory requirements - (got stuck here until folders were mannually created - seems folders needed are not created correctly [even though permissions for all folders and files were either 755, or even 7770
Page 3 - Diyhr Information page - here got the message [as noted]

"An unexpected error occurred.
Class '\Concrete\StartingPointPackage\Blank\Controller' not found "

needless to say - this is getting a bit frustrating....

footnote - I am trying to install on Dreamhost,cinm - which has Concrete5.6.3.1 as a "one-click" install and actually did use that - worked like a up and running Concrete5.6.3.1....BUT wanted to use a Concrete5.7 cleared out everything and started over with a 'manual' install of C5.7.3.1

((Not sure why but Concrete5.7.3.1 install package does not seem ready for prime time? what is causing these we need to know something more than just running an unzip and instlling?))

thanks for any help!!
roscoeh replied on at Permalink Reply
Where are you installing? I was installing on a remote server so what I did was simply install locally and then deploy to the remote server. With and SQL dump and ftp the files.
leal replied on at Permalink Reply 1 Attachment
Installing on host site:

They have a 'one-click' installation for Concrete5.6.3.1 - which I first used, and worked great! I have also used same on other website of mine (on with the 5.6 version.

However, i wanted to use a 5.7 thought to just install on site..the was put on site, then used pUTTY to unzip and install.

I would assume that the program would properly create itself...but seems like it isn't doing all it should.

Right now am stuck on Page 3 of install page (Site Information/Database Information)
with this error:
An unexpected error occurred.
Class '\Concrete\StartingPointPackage\Blank\Controller' not found
< Back to Home
I am only on a personal computer and haven't taken time or effort to install databases, etc.

If 5.7 install still in the manual kluge stage I will just go back to 5.6 until 5.7 is ready for prime time. Right now it seems it isn't (ready for prime time.) Have not found instrucitons for installing very gets you to Page 1 and then expects everything to work..but as isn't.
niijel replied on at Permalink Reply
just got the same error on a clean install so you are not alone. I too am going to wait a while longer for these issues to be ironed out!


{"error":{"message":"Concrete\\Controller\\Install::run_routine(): Failed opening required '\/var\/www\/HP\/concrete\/application\/config\/site_install.php' (include_path='\/var\/www\/HP\/concrete5.7.3.1\/concrete\/vendor:.:\/usr\/share\/php:\/usr\/share\/pear')"},"errors":["Concrete\\Controller\\Install::run_routine(): Failed opening required '\/var\/www\/HP\/concrete\/application\/config\/site_install.php' (include_path='\/var\/www\/HP\/concrete5.7.3.1\/concrete\/vendor:.:\/usr\/share\/php:\/usr\/share\/pear')"]}
Steevb replied on at Permalink Reply

I've had the same error as you on over a dozen install attempts. My hosting provider managed to install once.

I'm wondering if it's a 'cloud' server thing. I'm going to ask them to try again and also try with a sub domain.

Works every time locally, but will not work remotely??
leal replied on at Permalink Reply
SUCCESS! After an absolute cleaning - need to be able to remove all files and directories created by a Concrete5 install.

------------------programs used-------
Hosting service: (provides ftp which was used per below)
SHS Shell: pUTTY ( )
Firefox FTP: used (fastest ftp for me)

<caveat - information below is from personal experiece installing Concrete5.7..3.1 after a 'failed' attempt. My problems may have been started when i (erroneously) unzipped the on a local computer and then uploaded that to the website. That of course did not work...but then trying to start over without going back to the very beginning, i was able to hobble along until still getting stuck. Taking frz advice to "start over" i did the following and had no problems. In fact just for fun (;/) i did it twice....doing a complete cleanup in between, and each time it worked - when a clean install with a cleared database too.)

it seems that not all ftp or other programs show everything - so that is important to get rid of absolutely everything.

I use pUTTY (Windows) to then delete all directories, all files, to an absolutely empty website.

Also - Concrete5.7.3.1 wants to be installed by uploading the zip file to the website and then unzipping it there.

So starting absolutely fresh meant (my experience):

1. deleted everything and all, and use my web service ftp, a browser ftp (firefox ftp) and pUTTY shell to verify i had a completely clean website.

2. downloaded a fresh version of

3. ftp to the website directly (not using any sub-folders as the instructions seem to indicate - when a sub-folder is made and is put there...the program creates itself on that sub-folder, so the web address 'home' is on INSTEAD of what would be expected:

4. use a shell program (pUTTY in Windows worked smoothly for me) to then used the unzip command (comes with pUTTY) to unzip the file.

5. then just going to website, Concrete5.7.3.1 installs itself in a jiffy.

Extra credit - ALSO ALSO - need to have access to your database and DELETE ANY DATABASE ITEMS too (but NOT the database itself...just its contents - you keep the same database). This is important - if you started to install (it seems
Concrete5.7 is a much more larger program, C5.6 had about 150 database items, and C5.7 has more than 250 - quite a change!)

I used phpmyadmin i had available from my hosting service to get to the database and just drop (delete) everyting - cleaned house. I kept the same Mysql database, i just deleted the contents.

When Concrete5.7.3.1 installs itself, it will not work if this is not done. But it will gladly (it seems) install itself to the MySQL (empty) database.

I have used 5.6 and find learning the 5.7 navigation easy - and much more sophisticated.

Worth the effort if starting a new website for sure!
dlcsVGSInet replied on at Permalink Reply 1 Attachment
I would not install on any site. Too many random errors occur. It has been said that 5.7 was a WIP, so I would wait until there is a stable release.

As an example, 19in monitor in landscape, maximize fire fox and load, restore down firefox to about 2/3 the width of your 19in screen. Still looks ok. Maximize firefox and in a new tab load any users page that has at least one reward badge. For instance mine and scroll down for the badges won. Restore down firefox. Notice the left margin. Now hover over the badge and notice that the infobox is cut off on the left side. I do not know if they are using Concrete for this site, although that is about the same thing that occurs randomly while editing your content. I did a rotation on a block and was not able to select it again as the info/selection box that comes up, must have done so completely off the page.

If you are new to Concrete or are trying to use it on a live site, you are likely to have an easier time with a previous version. I went to 5.6 to actually be able to get the internal installer to work for the plugins and themes.
leal replied on at Permalink Reply
See my reply to Steevb - i found I needed to first clean house completely, and verify that there is absolutely no residual code, folders, etc. on the website; and clearing the MySQL database of all items (can keep the database, just be sure nothing is in it from a previous install)

BTW - to make sure i was able to do a proper install of 5.7, i went back and actually installed C5.6 on the web site...and that worked ok. So then I did a thorough cleaning up of that install...and went forward with a new C5.7 install - worked like a charm.

(I think C5.7 is so much more sophisticated (complicated?) that it really wants to be in charge and not have anything else on the site before it starts the install.)