installation error "Class 'Concrete\\Core\\Permission\\Category' not found"

Permalink 1 user found helpful
Hello

Tried to install C5 Version 8.4.3, got twice the message:

{"error":{"message":"Class 'Concrete\\Core\\Permission\\Category' not found"},"errors":["Class 'Concrete\\Core\\Permission\\Category' not found"]}

Install procedure starts correct. Choose language "german". Requirements checked and all ok (server running PHP 7.2.11).
After filling in the informations (website and database-connection) install procedure goes to step "Datenbank wird erstellt" (= creating database), runs through.
Right upon start of next step "Administrator wird angelegt" (= creating administrator) installation process stops and I get the above error message.

Checking the database it created 250 tables. Getting the error on installation procedure trying to create the administrator I noticed the 3 last tables in the database: UserPermissionEditPropertyAccesslist, UserPermissionEditPropertyAttributeAccessListCustom and UserPermissionViewAttributeAccessList. They are empty.

Trying installation the second time, I got an error message saying, the database must be empty, so I deleted all tables. Second trial failed then at the same installation step with the same error message.

I am not a developer, have no programming knowledge.

Tried to find help in forums and internet search, but no success.

Any comment and help would be greatly appreciated.

Thanks

View Replies: View Best Answer
mnakalay replied on at Permalink Best Answer Reply
mnakalay
Depending on how you uploaded concrete5 to the server you might have missing files.

If you uploaded the zip fie directly and unzipped it right on yur server that's probably not the issue.

If on the other hand you unzipped it on your computer and then uploaded the unzipped folder, you might have missing files as it happens sometimes.

If you're in the second situation, I suggest starting over, emptying the database and the files, uploading the zip file and unzipping it on the server using your Cpanel or whatever management dashboard your host provides you with. Then try again.
dessisan replied on at Permalink Reply
In fact, I had unzipped the zip-file on my computer and uploaded the files with filezilla. This, because the provider of this website, I take care of, offers no zipping-/unzipping through his server-dashboard. As filezilla didn't show any failures on upload I trusted the upload to be complete.

As you suggested I emptied the folder on the server, uploaded the zip-file and on my phone call the provider support unzipped it on the server. Installation then went ok.

So thank you for your helpful comment!

Strange enough, the unzipped folder 'concrete5-8.4.3' on my computer shows size 89,2 MB, whereas the unzipped folder on the server after unzipping showed size 122,6 MB.

Any idea about this? Maybe hidden files, which my computer doesn't take in account calculating the folder-size and then on uploading file-by-file with filezilla do not get uploaded?! Seems unprobably to me, as filezilla handles also hidden files.

I run OSX Yosemite 10.10.5 on a hackintosh. Switching the folder views to show the hidden files doesn't change the size of the unzipped folder on my computer and on first glance I couldn't detect any hidden files in it. On the other hand, when I check the folder-information separately (cmd + I), it shows size 117,6 MB, instead of 89,2 MB, this independently of switching 'show hidden files" on or off.

Anyway, installation worked now and I thank you for your input!
mnakalay replied on at Permalink Reply
mnakalay
Concerning FileZilla missing on files it happens sometimes and it's a pain. It is just never a good idea to upload something with that many files in unzipped form through FTP. It takes forever and it's prone to errors.

As for the file size difference, that's normal. There's the size and there's the size on disk. On my computer the size is 84.6Mo and the size on disk is 111Mo

Here's an article explaining the difference:http://www.differencebetween.net/technology/difference-between-size...
dessisan replied on at Permalink Reply
Thanks for the link about explaining size differences. I learned something new. 👍🏼