Installation Fails

Permalink
Unable to install database: 42000.

Trace:
#0 [internal function]: Concrete\Core\Package\StartingPointPackage->install_database() #1 C:\xampp\htdocs\devel\concrete\concrete\controllers\install.php(273): call_user_func(Array) #2 [internal function]: Concrete\Controller\Install->run_routine('elemental_full', 'install_databas...') #3 C:\xampp\htdocs\devel\concrete\concrete\src\Controller\AbstractController.php(156): call_user_func_array(Array, Array) #4 C:\xampp\htdocs\devel\concrete\concrete\src\Routing\ControllerRouteCallback.php(25): Concrete\Core\Controller\AbstractController->runAction('run_routine', Array) #5 C:\xampp\htdocs\devel\concrete\concrete\src\Routing\Router.php(115): Concrete\Core\Routing\ControllerRouteCallback->execute(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Routing\Route), Array) #6 C:\xampp\htdocs\devel\concrete\concrete\src\Support\Facade\Facade.php(119): Concrete\Core\Routing\Router->execute(Object(Concrete\Core\Routing\Route), Array) #7 C:\xampp\htdocs\devel\concrete\concrete\src\Application\Application.php(390): Concrete\Core\Support\Facade\Facade::__callStatic('execute', Array) #8 C:\xampp\htdocs\devel\concrete\concrete\src\Application\Application.php(390): Concrete\Core\Support\Facade\Route::execute(Object(Concrete\Core\Routing\Route), Array) #9 C:\xampp\htdocs\devel\concrete\concrete\bootstrap\start.php(256): Concrete\Core\Application\Application->dispatch(Object(Concrete\Core\Http\Request)) #10 C:\xampp\htdocs\devel\concrete\concrete\dispatcher.php(36): require('C:\\xampp\\htdocs...') #11 C:\xampp\htdocs\devel\concrete\index.php(2): require('C:\\xampp\\htdocs...') #12 {main}

MySql version: 5.7.9-log - MySQL Community Server (GPL)
Apache/2.4.7 (Win32) OpenSSL/1.0.1e PHP/5.5.23

1 Attachment

View Replies:
JohntheFish replied on at Permalink Reply
JohntheFish
Not sure if this is the same issue, but there have been glitches installing the sample content on windows running older versions of MySQL where setting foreign keys have caused crashes.

You could try installing the core without the sample content.

Or if you are on a dev system, you can try delete the foreign key statements from the sample content installer. The database will work, just a little slower on some queries (and faster on others).
SDH replied on at Permalink Reply
I have just had the same error message when trying to install in a subdirectory on my live server (FastHosts).

I think it is probably due to lack of permissions for the MySQL User account. After trying various things unsuccessfully, I eventually deleted the User (for the concrete5 database) and then added a new User (with the same name as before), but this time clicking on 'Give this user DBO access'. (I also deleted and then re-created the database). Concrete5 then successfully installed!

Note: on my host (FastHosts) some of the MySQL management is performed differently compared with using my local MAMP set-up. Adding a new database, new users, or setting users' privileges is done using the control panel, not phpMyAdmin.

I also had privilege problems the first time I tried to install Concrete5 on my local computer under MAMP, but got a different error message:
SQLSTATE[HY000] [1045] Access denied for user 'concrete5'@'localhost' (using password: YES)

Using phpMyAdmin to enable all privileges (except SUPER) fixed this problem.
besanalbasuni replied on at Permalink Reply 1 Attachment
I've been trying to get 5.7 installed but Unable to install database

Unable to install database: Could not create the proxies directory. Please check the file permissions of the proxy directory: /home/samills/public_html/New/application/config/doctrine/proxies..

Kindly find attached
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi besanalbasuni,

Have you checked the server file permissions to make sure these paths are writable?