Installing Concrete5 on WAMP - Server Not Found [SOLVED]

Permalink
I've downloaded WampServer for the first time and I followed this tutorial:

https://www.concrete5.org/documentation/how-tos/designers/installing...

Everything seemed to be working fine, up until I put the extracted concrete files into my wamp\www\project\ directory.

When I go back to localhost from the wamp server and click on my project, instead of taking me to the concrete installation page, I am greeted with a "Server not found" error by Firefox.

Any ideas?


Thanks!

View Replies: View Best Answer
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi jd42,

What version of concrete5 are you using?
jd42 replied on at Permalink Reply
I'm using 5.7.3.1.
MrKDilkington replied on at Permalink Reply
MrKDilkington
Just to double check, all the WAMP services are running?
jd42 replied on at Permalink Reply
Yeah, it appears so.
MrKDilkington replied on at Permalink Reply
MrKDilkington
If you type "localhost" into your address bar, what do you see?
jd42 replied on at Permalink Reply 1 Attachment
This screen.
jasteele12 replied on at Permalink Reply
jasteele12
First guess, check the .htaccess file in your project directory.

Try sticking a phpinfo.php in there:

<?php
phpinfo();
?>

What shows up if you try this URL? http://localhost/test/phpinfo.php...
jd42 replied on at Permalink Reply 1 Attachment
Thank you!

I added this document and that subdomain takes me to the attached page.

As I thought, it must somehow be a problem with the way I put the concrete files in the project folder.

What is the correct way to put them in?
jasteele12 replied on at Permalink Reply
jasteele12
You didn't respond to if you had a .htaccess file in your test directory...
MrKDilkington replied on at Permalink Reply
MrKDilkington
@jd42

If you are open to using XAMPP instead of WAMP. I can write up a tutorial on how to install and configure it, including how to install concrete5 5.7.
jd42 replied on at Permalink Reply
Thank you very much for the offer!

It seems like this problem should have a simple solution. I hate to go through a whole other process just to have the same problem pop back up.

So before I do that, are there any other simple errors that could've caused this?

For instance, my project name originally was two words with a space inbetween, and when I clicked on it absolutely nothing would happen. Once I took away the space it tried to load the site, but I received the "server not found" error. I just tried it again and it returned a blank page with an empty red rectangle at the top.

Could there be a problem with the way I put the Concrete5 folder in the project directory?

I extracted the folder, and pasted the extracted folder with all of it's contents into the project directory.

I can't think of anything else...Maybe I'll try redownloading concrete and putting it back in the project folder.

If you've no other ideas though, I'll definitely look into XAMPP.


Thanks!
jasteele12 replied on at Permalink Best Answer Reply
jasteele12
I've used pretty much every combination of webservers and php/mysql stacks since Xitami/PHP3/MySQL in 1995 (beta tester).

Probably the simplest today is the Bitnami concrete5 stack installer:
https://bitnami.com/stack/concrete5/installer...
It's literally click and run concrete5 (not only windows, but Linux and OSX).

One of my current favorites is the Uniform Server (since I don't need duplicates of Python/Perl/etc and I *hate* phpMyAdmin (much better tools available):
http://www.uniformserver.com/

The reason I like both of these is that they are standalone and require no registry modifications (read portable). Uniform server has the smallest footprint.

FYI,

John
jasteele12 replied on at Permalink Reply
jasteele12
If your "project" (read directory name) had a space in it you are asking for trouble.

If you want to try your current setup again (which appears fine from the phpinfo() - delete your database and install c5 fresh again into your new directory.

Spaces in directories or URLs are evil :-P
jd42 replied on at Permalink Reply
Apologies, my mind somehow skipped over that bit.

Upon further inspection it would seem that NO, I don't have an htaccess file in my projects directory.

________________________________________________



Thanks for the recommendations,I'll look into those as well.


________________________________________________



Ah. First, if you would, please tell me more about this illusive "htaccess" monster. After this fierce beast has been caught and skinned, I will consider restringing my WAMPing hunting bow.
jasteele12 replied on at Permalink Reply
jasteele12
.htaccess (dot ht access) can control how the Apache server works in a given directory, it is for instance used when you enable Pretty URLs in concrete5.

It can also make weird things happen if it not strictly written (especially ReWrite rules), which theoretically could cause a Server not found error message.
jd42 replied on at Permalink Reply
Ok, thanks.



So I deleted the directory for my project, created a new one, added the concrete files, and I'm still getting the server not found message.

I hate to leave this unsolved, but perhaps its time to check out one of those other local servers...
jasteele12 replied on at Permalink Reply
jasteele12
So you can't even get to the concrete5 install screen?

http://localhost/your_dir/phpinfo.php... still works (after creating one there)?
jd42 replied on at Permalink Reply
Correct on both accounts!

However, I am happy to report that I have downloaded Uniform and successfully installed Concrete5.

Hazah!

Thank you both for the help!
jasteele12 replied on at Permalink Reply
jasteele12
Excellent news!

If you wouldn't mind adding [SOLVED] to your original post and picking a best answer that would be great.

I do like Uniform Server (which I used reviewing Remo's concrete5 Beginner's Guide [2nd Ed], but he was using a Bitnami stack just as successfully.

I actually have several different versions of Uniform running in different directories with different versions of PHP/MySQL and concrete5. Super easy to switch between them.
theneptune replied on at Permalink Reply
theneptune
Its really helpful.
Thanks