Internal Server Error during installation on MAMP

Permalink
I'm getting "Internal Server Error" right after "Adding block types" during the installation process on MAMP.

The whole text error is:

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log."

Apache log

Marker - 01 Feb 2016 19:48:04
[Mon Feb 01 19:50:14 2016] [error] [client 127.0.0.1] FastCGI: comm with server "/Applications/MAMP/fcgi-bin/php5.5.18.fcgi" aborted: idle timeout (30 sec), referer:http://concrete5:8888/index.php/install...
[Mon Feb 01 19:50:14 2016] [error] [client 127.0.0.1] FastCGI: incomplete headers (0 bytes) received from server "/Applications/MAMP/fcgi-bin/php5.5.18.fcgi", referer:http://concrete5:8888/index.php/install...


Can you please help to overcome this issue?

View Replies:
AndyJ replied on at Permalink Reply
hi,
the following link might help you out:

http://craftcms.stackexchange.com/questions/4661/fastcgi-error-when...

but make sure if you do make any changes to your httpd.conf that you can either easily backout or restore the original file and take care that the php version number you add matches yours.
enri replied on at Permalink Reply
Thank you for your answer.

When I add the string:

FastCgiServer /Applications/MAMP/fcgi-bin/php5.3.29.fcgi -idle-timeout 3600


I get the error while Apache is starting:

"Apache couldn't be started. Please check the log file for more information.

Syntax error on line 642 of /Users/vi/Library/Application Support/appsolute/MAMP PRO/httpd.conf:
FastCgiServer: redefinition of a previously defined FastCGI server "/Applications/MAMP/fcgi-bin/php5.3.29.fcgi""

There is nothing appears in apache log


My part of httpd.conf looks like that now

<IfModule mod_fastcgi.c>
# URIs that begin with /fcgi-bin/, are found in /var/www/fcgi-bin/
Alias /fcgi-bin/ "/Applications/MAMP/fcgi-bin/"

# Anything in here is handled as a "dynamic" server if not defined as "static" or "external"
<Directory "/Applications/MAMP/fcgi-bin/">
SetHandler fastcgi-script
Options +ExecCGI
</Directory>

# Anything with one of these extensions is handled as a "dynamic" server if not defined as
# "static" or "external". Note: "dynamic" servers require ExecCGI to be on in their directory.
AddHandler fastcgi-script .fcgi .fpl

MAMP_ActionPhpCgi_MAMP

# MAMP_FastCgiServer_MAMP
FastCgiServer /Applications/MAMP/fcgi-bin/php5.3.29.fcgi -idle-timeout 3600
</IfModule>
AndyJ replied on at Permalink Reply
hello - Apache doesn't like the change.

Are you able to reverse it out and put the file how it was before.

It is complaining that that path is already defined - and you are not allowed to do that.

So, reverse the change out. Then find where it is defined and then change the timeout to the larger figure.

One thing I can't work out is where you got php5.3.29.fcgi from?
enri replied on at Permalink Reply
>>Are you able to reverse it out and put the file how it was before.

Yes I deleted the string I added, uncommented original value and it has started ok

>>So, reverse the change out. Then find where it is defined and then change the timeout to the larger figure.

Skimmed over the https.conf but did not find where it was defined

>>One thing I can't work out is where you got php5.3.29.fcgi from?

I have MAMP Pro 3.0.7.3 and this version of PHP is set by default but I tried other versions too (
AndyJ replied on at Permalink Reply
your original error showed this:

from server "/Applications/MAMP/fcgi-bin/php5.5.18.fcgi",

what if you make the change to httpd.conf again but using this version number?

Again, remember to make sure you can reverse it out.

If you get the same error on being unable to start Apache again you'll need to reverse out again and find the other file that it is defined in.
enri replied on at Permalink Reply
>>your original error showed this:

>>from server "/Applications/MAMP/fcgi-bin/php5.5.18.fcgi",

Thats because in first place I was running that version but later I switched it to default 5.3.29

what if you make the change to httpd.conf again but using this version number?

I will try it now )
enri replied on at Permalink Reply 1 Attachment
If I add the string suggested on your link to httpd.conf Apache fail to start with the error bellow

Starting Apache Failed

Apache couldn't be started. Please check the log file for more information.

Syntax error on line 643 of /Users/vi/Library/Application Support/appsolute/MAMP PRO/httpd.conf:
FastCgiServer: redefinition of a previously defined FastCGI server "/Applications/MAMP/fcgi-bin/php5.5.18.fcgi"

I have attached httpd.conf
enri replied on at Permalink Reply
It looks like it is a syntax error

It says:

Syntax error on line 643