Issue during installation

Permalink
Hello,

I am trying to install Concrete 5 on an OVH hosted new website. I have done this successfully about 10 times in the past.

Now I have this error message when I launch the C5 installation on the new site :

Unable to install database: Declaration of Concrete\Core\Attribute\Key\CollectionKey::getList() should be compatible with Concrete\Core\Attribute\Key\Key::getList($akCategoryHandle, $filters = Array).

Trace:
#0 [internal function]: Concrete\Core\Package\StartingPointPackage->install_database() #1 /home/charancoyg/www/concrete/controllers/install.php(273): call_user_func(Array) #2 [internal function]: Concrete\Controller\Install->run_routine('elemental_full', 'install_databas...') #3 /home/charancoyg/www/concrete/src/Controller/AbstractController.php(156): call_user_func_array(Array, Array) #4 /home/charancoyg/www/concrete/src/Routing/ControllerRouteCallback.php(25): Concrete\Core\Controller\AbstractController->runAction('run_routine', Array) #5 /home/charancoyg/www/concrete/src/Routing/Router.php(115): Concrete\Core\Routing\ControllerRouteCallback->execute(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Routing\Route), Array) #6 /home/charancoyg/www/concrete/src/Support/Facade/Facade.php(119): Concrete\Core\Routing\Router->execute(Object(Concrete\Core\Routing\Route), Array) #7 /home/charancoyg/www/concrete/src/Application/Application.php(376): Concrete\Core\Support\Facade\Facade::__callStatic('execute', Array) #8 /home/charancoyg/www/concrete/bootstrap/start.php(246): Concrete\Core\Application\Application->dispatch(Object(Concrete\Core\Http\Request)) #9 /home/charancoyg/www/concrete/dispatcher.php(36): require('/home/charancoy...') #10 /home/charancoyg/www/index.php(2): require('/home/charancoy...') #11 {main}

Anyone knows what could be the issue ?
I have contacted OVH and they have no clue. They say it is a C5 issue,

Thanks
Oliier

View Replies:
Gondwana replied on at Permalink Reply
Gondwana
I suspect it's related to php version. New versions of php are stricter about checking for argument list compatibility.
ramonleenders replied on at Permalink Reply
ramonleenders
Which version are you trying to install?