Lost All My Pages :(

Permalink
Hello,

I discovered today that my client's Concrete 5 site is broken. I have no idea how it happened. Take a look:http://www.bmfusa.com/

Only the homepage works. All the other pages are broken. There is not dashboard. No login page.

What can I do to fix this? I tried reinstalling the newer version just by copying all the files to see if it would fix this, but it broke the entire site so I put 5.5.0 back.

Thanks!

View Replies:
oscarkool replied on at Permalink Reply
Bump
landollweb replied on at Permalink Reply
landollweb
Have you always had pretty URLs enabled?
DAkers replied on at Permalink Reply
Hey oskarcool,

I may have figured out what is going on. I think all of your permissions are out of wack and the view permission on all pages are set to none. Login by going here:

http://www.bmfusa.com/?cID=2

After logging in, this should take you to some page on your site but you should see the toolbar on the top. You should be able to get to your dashboard and I would check your permissions in the sitemap on your pages.

It could also just be that pretty URLs are disabled or messed up as well. But you should be able to get to your dashboard and fix it with the method above.
apc123 replied on at Permalink Reply
apc123
I'm having this problem today with a GoDaddy client. GoDaddy claims the only change they've made is upgrading Apache from 2.2 to 2.4.

From looking around it looks as though they are also now ignoring the php.ini file in the client directory. As a bonus the DB is now throwing an error.

My only hope from this is that the client decides to listen to reason and leave GoDaddy.
hollyb replied on at Permalink Reply
I'm dealing with the exact same issue. Check out my thread here:

http://www.concrete5.org/community/forums/customizing_c5/pretty-url...

Not sure if the solution suggested works as I haven't tried it. But its worth a look.
oscarkool replied on at Permalink Reply
Hey Dakers you got me farther than I've gotten yet. Do you know the non-pretty URL for the login? Because after I do login, I get sent tohttp://www.bmfusa.com/login/do_login/... and then it's another Page Not Found :(

So looks like I need the non-pretty url version for the dashboard or something like that.
DAkers replied on at Permalink Reply
My dashboard cID is 2, so that may be the same for you.

After logging in, try going back to this page.

http://www.bmfusa.com/?cID=2

Is it another page not found? Or does it keep trying to ask you to log in?
oscarkool replied on at Permalink Reply
Yea when I login it just says page not found athttp://www.bmfusa.com/login/do_login/... and if I go back tohttp://www.bmfusa.com/?cID=2 it's asking me to login again. Bah!
DAkers replied on at Permalink Reply
If you go to your home page after trying to log in, does the tool bar on the top appear?
oscarkool replied on at Permalink Reply
No :(
oscarkool replied on at Permalink Reply
Anyone?
madeforspace replied on at Permalink Reply
madeforspace
Hi oscarkool

I had a very quick look at your site and my 'guess' is that you have an .htacess problem on your site related to your pretty URL's.

When I tried to view your site I got the homepage as you said but when I tried other pages I got the 404 message.

I then added /index.php/ into one of your urls and got the error message 'No input file specified.'

If you put that term into the concrete search box at the very top of this page on this site you will see a list of other conversations with similar problems and some fixes.

Sorry I dont have the time to dig further but this hopefully will point you in the right direction (I hope).

Hope that helps.
apc123 replied on at Permalink Reply
apc123
I'm still waiting to hear from GoDaddy. From checking the php setup it seems when they upgraded Apache they reconfigured their php setup and turned on FastCGI while also ignoring local php.ini files.

I only have one client that uses GoDaddy and the long-term solution is to avoid GoDaddy. It's not the fastest solution but going to another webhost is the best solution I've come up with.
oscarkool replied on at Permalink Reply
I'm also on Godaddy so maybe that's it. But still, it's an annoying problem indeed!
mlocati replied on at Permalink Reply
mlocati
I posted a possible solution in the other post aboit GoDaddy:
http://www.concrete5.org/community/forums/installation/godaddy1/#51...

Please remark that it is just a suggestion... Keep a backup of your previous .htaccess
oscarkool replied on at Permalink Reply
Thanks for the help. Unfortunately this did not fix my issue. Maybe the only option is moving to wordpress because I just can't have a client site down for too long...
mkly replied on at Permalink Reply
mkly
Hi Everyone,
With the holiday in the US, we are just getting word of this issue. I'm going to look into it a bit more today, but in the meantime here is some quick info to hopefully get you back up and running.

1. "Pretty URLs" is essentially the process of reading the URL passed in and adding in "index.php" so that visitors do not need to type that part in.

2. With Pretty URLs enabled concrete5 will change links so that they do not include the index.php. So if you have Pretty URLs enabled, but the .htaccess file is not there(or not working) you will get page not founds.

3. When GoDaddy made this switch it is likely that your .htaccess needs a change. Guess I know what I'm doing with my Sunday ;) I'll set up an Apache 2.4 instance and see if I can get us a work around for this.

4. In the meantime you can disable Pretty URLs(change example.com to your domain).

a. Login into your site
http://www.example.com/index.php/login

- Don't worry if this sends you to a page not found etc. The session is set and that's all we need.

b. Browse to
http://www.example.com/index.php/dashboard/system/seo/urls/

- Uncheck the box "Enable Pretty URLs" click "Save"

c. Browse to
http://www.example.com/index.php/dashboard/system/optimization/clear_cache/

- Click "Clear Cache"

If you are still having issues you can check the file located at
/config/site.php

and look for
define('URL_REWRITING_ALL', true);

If that is there comment it out so it looks like
//define('URL_REWRITING_ALL', true);


Let me know how that goes and we'll take it from there.

I'll also suggest that anyone here take a look at our recommended hosts section
http://www.concrete5.org/marketplace/hosting/...

All of these hosts are so much better than GoDaddy. So. Much. Better.

Best Wishes,
Mike
oscarkool replied on at Permalink Reply
See this doesn't work because 'index.php/login' doesn't work. It gives me a Page Not Found :)
mkly replied on at Permalink Reply
mkly
Server version: Apache/2.4.4 (Debian)

Ok, I've tested my latest 5.6.1.2dev branch(the github one) with the above version of Apache. Pretty URLs appear to be working with that. Here is the .htaccess we currently install when you enable "Pretty URLs".
# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>
# -- concrete5 urls end --

Give that a shot. If this doesn't work, then it is likely that there is an additional difference beyond simply a switch from Apache 2.2 and Apache 2.4

Best Wishes,
Mike
oscarkool replied on at Permalink Reply
See this doesn't work because 'index.php/login' doesn't work. It gives me a Page Not Found :)
oscarkool replied on at Permalink Reply
If I go tohttp://www.bmfusa.com/index.php/dashboard/system/seo/urls/... I get an error and I have no idea how to fix that.

This seems like a more serious error than just Godaddy, but I can assure you that there was no harm done on our end. This issue just popped up out of the blue.
cramaekers replied on at Permalink Reply
cramaekers
I'm experiencing the exact problems discussed here and have tried all of the .htaccess suggestions. Any other ideas? Hopefully someone comes up with a solution soon!
cramaekers replied on at Permalink Reply
cramaekers
Whoops. Double post. Delete!
Solutionmaven replied on at Permalink Reply
This worked for me both for the front end and the admin. Yey!
jasonj replied on at Permalink Reply
We have a site on godaddy that has the same problem. We were able to get the front end working but still can't access the admin.

htaccess looks like this
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?$1 [L]


Then, in /config/site.php, add this line to the end...
define('SERVER_PATH_VARIABLE', 'QUERY_STRING');


The problem seems to be apache refusing to serve files that have trailing characters after the .php extension (index.php/dashboard/) that aren't preceded by a '?'.

This only fixed the front end for us. Still no luck on the admin.
Solutionmaven replied on at Permalink Reply
Same here. Used your code suggestions and got the front end working. However, in the process of troubleshooting, I created a new page which I'd dearly like to delete! However, I've lost all editing capability. Once I leave the dashboard, I can't get back to it. Hope you find a solution that addresses the admin part!! Thanks!
Solutionmaven replied on at Permalink Reply
Same here. Used your code suggestions and got the front end working. However, in the process of troubleshooting, I created a new page which I'd dearly like to delete! However, I've lost all editing capability. Once I leave the dashboard, I can't get back to it. Hope you find a solution that addresses the admin part!! Thanks!
Solutionmaven replied on at Permalink Reply
Same here. Used your code suggestions and got the front end working. However, in the process of troubleshooting, I created a new page which I'd dearly like to delete! However, I've lost all editing capability. Once I leave the dashboard, I can't get back to it. Hope you find a solution that addresses the admin part!! Thanks!
oscarkool replied on at Permalink Reply
Site is still broken.

While we can all blame Godaddy for this, it's quite ridiculous that Concrete 5 developers haven't been able to come up with a solution.

Converting to wordpress, good luck to all.
Adreco replied on at Permalink Reply
Adreco
In viewing your site with chrome tools, I noted that your Home page nav is all links to pretty URLs (which seem to be the problem?) and all your internal pages are visible And link to each other from the nav bar with no problem.
Is your home page navigation hardcoded?
This would obviously give an error if your .htaccess is problematic.


Adrian

Arvixe Web Hosting / Concrete5 Community Liaison |
http://www.arvixe.com/concrete5_hosting...............
jkincaid replied on at Permalink Reply
So - both of the sites I have hosted at GoDaddy failed due to pretty url issues. This is not an issue on other hosting companies that I use.

I worked again tonight with GoDaddy seeing if they had discovered any solutions.

The following code is what I have in my .htaccess file now. What is interesting is that I have pretty URL's turned on but I am still seeing the full url (with index.php etc in it).

What is odd is that this worked until this week - even though my other GoDaddy sites didn't.

I have pretty url's embedded in Flash and didn't want to change them.

Anybody see any syntax errors in the below that would cause the redirect to the full URL instead of the rewritten pretty url?

Thanks.

Seth

# -- concrete5 urls start --
<IfModule mod_rewrite.c> 
RewriteEngine On 
RewriteBase / 
RewriteRule ^(default.htm)/?$ index.php 
RewriteRule ^(default.html)/?$ index.php 
RewriteCond %{REQUEST_FILENAME} !-f 
RewriteCond %{REQUEST_FILENAME} !-d 
RewriteRule ^(.*)$ http://%{HTTP_HOST}/gallery/index.php/$1 [L] 
</IfModule>
# -- concrete5 urls end --
Droid replied on at Permalink Reply
I am facing the same issue.