Migrating Site

I recently migrated a site to a new server. Everything was working fine for a little while. Then when i went into the backend and typed in my password, I started receiving this error:

Warning: mkdir() [function.mkdir]: Permission denied in /home/portal/public_html/denovo/concrete/libraries/3rdparty/adodb/adodb.inc.php on line 1703

Fatal error: Uncaught exception 'ADODB_Exception' with message 'mysql error: [-32000: Cache write error] in CacheExecute(/home/portal/public_html/denovo/files/cache/b2/adodb_b23a4e510edac9e996281b73ff42a730.cache, select ctID from PageTypes) ' in /home/portal/public_html/denovo/concrete/libraries/3rdparty/adodb/adodb-exceptions.inc.php:78 Stack trace: #0 /home/portal/public_html/denovo/concrete/libraries/3rdparty/adodb/adodb.inc.php(1785): adodb_throw('mysql', 'CacheExecute', -32000, 'Cache write err...', '/home/portal/pu...', 'select ctID fro...', Object(ADODB_mysql)) #1 /home/portal/public_html/denovo/concrete/libraries/database.php(31): ADOConnection->CacheExecute(10, 'select ctID fro...') #2 /home/portal/public_html/denovo/concrete/models/permissions.php(392): Database->querycache(10, 'select ctID fro...') #3 /home/portal/public_html/denovo/concrete/models/permissions.php(64): CollectionPermissions->CollectionPermissions(Object(Page)) #4 /home/portal/public_html/denovo/concrete/models/permissions.php(97): PermissionsP in /home/portal/public_html/denovo/concrete/libraries/3rdparty/adodb/adodb-exceptions.inc.php on line 78"

No matter what I have been doing I have not been able to fix this problem and get concrete working with my site once again. Any suggestions. Thanks in advance.

View Replies:
andrew replied on at Permalink Reply
1. Delete your files/cache/ directory - don't worry nothing important is stored in here.
2. Add a new, empty files/cache/ directory
3. Make sure this directory is writable by your web server, or by the world

chmod 777 files/cache/
DavidMIRV replied on at Permalink Reply
I've got this same problem on the migration of a site myself. I even tried doing a fresh install of C5 on the server environment to no avail.. php safe_mode is off.. What else could be wrong? I've double checked the perms in files/cache several times..
DavidMIRV replied on at Permalink Reply
Oh yea this is in a clustered environment also but that really shouldn't make a difference here..
drm replied on at Permalink Reply
We were getting a similar error despite perfect permissions and following any/all suggestions we got.

It turned out the only solution that worked was to not store the cache on our NFS mount (Multiple front end web nodes mounting a central file system.)

We created a cache directory in /tmp/ on all the web nodes and created a symlink in the c5 installation directory (eg: rm -rf files/cache/;ln -s /tmp/cache/ files/cache/)

This is not ideal but was the only method we could find to get us up and running with ADODB caching turned on. So, if you're running a similar NFS setup - this may be your problem too.
beeman89045 replied on at Permalink Reply
I'm getting this error as well. Have tried reinstalling as well as deleting files/cache.

I have gotten as far as getting the homepage working, but then this error crops-up again when attempting to login to Dashboard. And following the failed login, the homepage will stops rendering and throw this error again.

Strange thing is I have it working just fine on the same VPS under a "regular domain". I am getting this error when deploying and accessing from just an IP address (fake domain).

I am not sure if that has any bearing on this Error or not.
beeman89045 replied on at Permalink Reply
PHP SafeMode was the culprit in my case. I turned it off and all was back to normal (e.g. no more Cache Errors).

I installed C5 on a phony Domain in Plesk, but forgot to turn off SafeMode when setting up that domain.

All my other Domains have had it off for a long time; I must have just overlooked it on this new one.