Moved C5 from sub-domain to different domain

I cloned a started C5 from a sub-domain to a new domain.
C5 version is

All is good except when I then delete the original C5 from the sub-domain.
Then I get:
"SessionHandler::read(): open(/home/brody3421897/, O_RDWR) failed: No such file or directory (2)"

Yep, I understand that the cloned site is trying to access the database from the old sub-domain location. Hence when I delete it, I get an error message.

It needs to be looking in:
" /home/brody3421897/" where it is already installed

What I can't find is where do I change the websites settings for this.
Any help would be greatly appreciated.
As of now I can do it by re-installing it to the original sub-domain to makes changes in the back office or if someone knows the file path and file will work also.


View Replies:
Gondwana replied on at Permalink Reply
Possibly application/config/database.php

Full details:
TheChief replied on at Permalink Reply
Thanks for the reply!

I had come across the article and had already accessed that file.
I am not sure what needs changed.
Database, username, and password are correct.

As for the driver that is listed in the database.php file, I do not know where to check what godaddy says the driver is.
I also don't see a place in C5 to change the "Data File" (/home/brody3421897/.appdata/current/d53xlvy66sooc0wc4c08kg8gg) listed in the back office of Godaddy. It is locked in Godaddy and is different between the 2 installs. I cannot find any instructions that even talk about changing that path in C5.
So, I do not understand what I am missing.
I have called Godaddy and they said I need to change the url settings in C5 and as far as I know I did so in the back office. I could not find any others places to do so.

Not sure if this helps or not but I used Godaddy's database clone tool to move (as there instructions say) but their instructions are for wordpress only. After the clone (in wordpress) you are to change the permalinks settings. C5 as far as I know doesn't have a permalink setting. However, there is a setting which I would imagine is the same just called something different ( don't remember off hand what it was called) but I was able to input the new domain as the url.
BUT I still get the error message once I delete the original database.
If you happened to catch what I might be missing please offer some suggestions.

I guess if this does not work, I will try following the articles instructions for moving and not use the Godaddys clone tool and see if I get a different result.
hutman replied on at Permalink Reply
This doesn't really look like a database problem as much as a path problem. Have you tried deleting everything in the /application/files/cache directory?

Also, have you checked your /application/config files for anywhere storing the wrong URL?
TheChief replied on at Permalink Reply
I could not find any files listed in any said directories that had a place to change the URL.
I looked through the moving instructions page to see if I wanted to try that route and since it was a newly started C5 decided to skip that headache. I have kept the old one up and will be pulling pictures and content off as I rebuild a new C5.