Moving Concrete5 site from Linux to a Windows Server


What problems should I be aware of from moving a Concrete5.4.2.2 website that is presently hosted on a Linux server onto Windows Server 2008 / IIS 6?

Have had no success so far, I don't know what the web designer has called his tables, as research has indicated there may be a case sensitive issue.

Is it possible to move from Linux to Windows?



1 Attachment

View Replies:
fowlesp replied on at Permalink Reply
There shouldn't be an issue.

If your using MySQL as the backend database (is there a choice in C5?) you'll find the table names need to be adjusted. In Linux they're case-sensitive, in Windows case-insensitive (check the docs as this may be the other way around)

The MySQLCaseInsenstiveHell Add-On (available in the Marketplace) will very neatly handle the conversion issue from Windows->Unix, so I would check whether there is a equivalent in the other direction

Alternatively you could export your tables in SQL and parse the file, convert the table cases

Whats actually happening?
blokeybloke replied on at Permalink Reply 1 Attachment
Hi Thanks for your reply

I am getting Server Error 401 - Unauthorized: Access is denied due to invalid credentials.

I am trying to install a new website from the web designer but it is currently hosted on a linux server and I have windows server 2008 / iis 6.0

The error message implies to me that the site.php could be wrong, but it should work with my info entered.

There is an attachment that I sent to the web designer detailing the problems with screenshots which people can look at, I had the default config5 website working okay...


P.s I shall be working on this throughout the day, so things may change but the word document details everything
fowlesp replied on at Permalink Reply
1. Use the site.php that worked

2. Replace your C5 installation with the files from your Web Designer

3. Import the database backup which should also come from your web designer
Mainio replied on at Permalink Reply
You should be ok moving the site FROM linux TO windows. When you import the database, the table names will automatically be lowercase in your windows database server if it does not have the option "lower_case_table_names=0" defined in the my.cnf of your database server.

@fowlesp pointed out an add-on that helps when you move the site FROM windows TO linux. We also have a free, MIT licenced add-on for the same purpose and IMO it's more feature rich than the commercial one:

That add-on is currently in the PRB queue and therefore not yet in the marketplace but you can download the zip from github.
blokeybloke replied on at Permalink Reply
Hi Thank you for your reply

At least now I know it can be done.

You say "when you import the database..." I have been sent a zipped up file and just extracted all those files in the relevant web folder on my server and changed the relevant details in the config file as per the web designers instructions in site.php (i.e BASE_URL and DIR_URL)

Should he or I be doing something in Mysql? I have not physically imported anything.

I have been using MySql for about a week.

I will read the link you sent now


Mainio replied on at Permalink Reply
Hmm, ok, you need to do a MySQL import of the site's database that is being moved. The backup itself (=database dump) can also be done through concrete5 UI by going Dashboard => System & Maintenance => Backup & Restore.

After doing a backup there, the file should be saved to

And the xxxxxxxx stands for a number pointing at the time of the backup.

For importing that file on the Windows server, you do need to know something about managing SQL servers but all I can say to you is that it's not really rocket science if you're good with computers.

Here's a basic level guide on how to do it:

Also, for more information, just google "import mysql dump" or "importing mysql dump", etc.

blokeybloke replied on at Permalink Reply

First can I thank the people here who gave me good advice on piecing my "jigsaw" together.

This is how my problem was solved...

I re-copied all the files from the web designer using Coffecup ftp rather than unzipping and extracting files.

I had already found out with the help given here I should create the database with database name and password name in the site.php file NOT just change the BASE_URL and DIR_URL. this seems obvious now but remember at the time I had zero Concrete5, Apache or MySql or PHPMyAdmin knowledge and had followed the installing a concrete5 site info to the letter. (Dreamweaver, Classic Asp, Adobe Master Collection CS2/CS3 is my primary skillset and I look after 2 Windows 2008 / iis7.0 web servers)

I then set the default page in IIS to Index.php

For Information, the web designer's one click host for concrete5 on linux had created a database name that contained 3 hyphens which was a problem as I could not create the database in MySql Server. Researh on the Internet mentioned this could be overcome using `backticks` but I still had problems then found out I was using the wrong backtick on the keyboard! there is a difference between using ' (underneath the @ symbol) and ` (top row, very first character on keyboard) which is the genuine backtick.

I now have other problems with the web site but these are web related issues that don't belong to this thread.

So thanks again for everybodies advice and A Happy new Year!

dbradley replied on at Permalink Reply
Here is how I did it:

1. Install WAMP and set up a concrete5 database with the same name as the one on my Linux box. I don't know if that helped or not.
2. I edited the my.ini file and changed max_allowed_packet from 1M to 10M (my dump file was 4M)
3. Copied the entire HTML directory from linux to WWW directory on WAMP.
4. Ran C:\wamp\bin\mysql\mysql5.5.20\bin> mysql -u root -p -h localhost databasename < C:\wamp\www\files\backups\dbu_1336500006.sql to do the import
5. Changed C:\wamp\www\config\site.php, updated username and password
6. Restarted WAMP services, logged in to C5 and cleared cache.


I found 2 major problems - some characters don't convert over correctly - symbols like : and ' become  and . I'm not sure why, trying to figure out a resolution there.